[Scipy-tickets] [SciPy] #516: import error for sparse module SciPy 0.6.0 with Windows binaries

SciPy scipy-tickets@scipy....
Sat Nov 10 11:49:09 CST 2007


#516: import error for sparse module SciPy 0.6.0  with Windows binaries
--------------------------+-------------------------------------------------
 Reporter:  jblunt        |        Owner:  somebody
     Type:  defect        |       Status:  new     
 Priority:  normal        |    Milestone:  0.7     
Component:  scipy.sparse  |      Version:  devel   
 Severity:  normal        |   Resolution:          
 Keywords:                |  
--------------------------+-------------------------------------------------
Comment (by catchmeifyoutry):

 hello, i have the same problem.

 WinXP [[BR]]
 Python 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)]
 on win32[[BR]]
 scipy 0.6.0[[BR]]
 numpy 1.0.3.1[[BR]]
 [[BR]]

 installed via the win32 installer executables.
 Here is a dir overview of the spicy.sparse package:
 {{{
 C:\Python25\Lib\site-packages\scipy\sparse>dir
  Map van C:\Python25\Lib\site-packages\scipy\sparse

 10-11-2007  18:37    <DIR>          .
 10-11-2007  18:37    <DIR>          ..
 18-09-2007  23:09             2.959 info.py
 10-11-2007  18:19             3.041 info.pyc
 10-11-2007  18:19             3.041 info.pyo
 18-09-2007  23:09             1.359 setup.py
 10-11-2007  18:19             1.002 setup.pyc
 10-11-2007  18:19             1.002 setup.pyo
 10-11-2007  18:33           103.651 sparse.py
 10-11-2007  18:33            91.662 sparse.pyc
 10-11-2007  18:19            91.599 sparse.pyo
 18-09-2007  23:09            27.968 sparsetools.py
 10-11-2007  18:19            31.498 sparsetools.pyc
 07-12-2006  22:46           402.379 sparsetools.pyd
 10-11-2007  18:19            31.498 sparsetools.pyo
 23-12-2006  19:30    <DIR>          tests
 19-09-2007  00:07         1.042.391 _sparsetools.pyd
 10-11-2007  18:19               207 __init__.py
 10-11-2007  18:19               577 __init__.pyc
 10-11-2007  18:19               577 __init__.pyo
               17 bestand(en)        1.836.411 bytes
                3 map(pen)     645.646.848 bytes beschikbaar

 }}}

 Apparently, the
 directory sparsetools is missing ??? I mean this dir:
 [http://projects.scipy.org/scipy/scipy/browser/trunk/scipy/sparse/sparsetools]
 [[BR]]

 This bug is annoying, because a lot of quick scripts use
 {{{
 from scipy import *
 }}}
 which fails now.[[BR]]

 As a quick fix, I just commented lines 21-28 in scipy/sparse/sparse.py:
 {{{
 import numpy
 #from scipy.sparse.sparsetools import cscmux, csrmux, \
 #     cootocsr, csrtocoo, cootocsc, csctocoo, csctocsr, csrtocsc, \
 #     densetocsr, csrtodense, \
 #     csrmucsr, cscmucsc, \
 #     csr_plus_csr, csc_plus_csc, csr_minus_csr, csc_minus_csc, \
 #     csr_elmul_csr, csc_elmul_csc, csr_eldiv_csr, csc_eldiv_csc

 #import sparsetools
 import itertools, operator, copy
 }}}
 ofcourse, this is not a real solution.

 Ok, hope this helps. Thanks.

-- 
Ticket URL: <http://scipy.org/scipy/scipy/ticket/516#comment:2>
SciPy <http://www.scipy.org/>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list