[Scipy-tickets] [SciPy] #738: Illegal Instruction

SciPy scipy-tickets@scipy....
Wed Sep 10 08:13:59 CDT 2008


#738: Illegal Instruction
----------------------------+-----------------------------------------------
 Reporter:  bernardo_rocha  |       Owner:  somebody
     Type:  defect          |      Status:  new     
 Priority:  normal          |   Milestone:          
Component:  Other           |     Version:          
 Severity:  normal          |    Keywords:          
----------------------------+-----------------------------------------------
 Hi,

 I was having some problems with scipy using the version provided by
 opensuse 11, science repository. Then I decided to use the code from the
 svn server, which I also did for numpy and the numpy.test() was OK. The
 test doesn't finish for scipy, it ends with an "Illegal Instruction"
 error. The same error I had before with the scipy rpm from opensuse11.
 Below is the output of scipy.test(level=1):

 {{{
 rocha@dc108164:~> python
 Python 2.5.2 (r252:60911, Aug  1 2008, 00:37:21)
 [GCC 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]] on
 linux2
 Type "help", "copyright", "credits" or "license" for more information.
 >>> import scipy
 >>> scipy.test(level=1)
 /etc/pythonstart:1: DeprecationWarning: This method's signature will
 change in the next release; the level, verbosity, all, sys_argv, and
 testcase_pattern keyword arguments will be removed. Please update your
 code.
   # startup script for python to enable saving of interpreter history and
 Running unit tests for scipy
 NumPy version 1.3.0.dev5802
 NumPy is installed in /usr/local/lib64/python2.5/site-packages/numpy
 SciPy version 0.7.0.dev4722
 SciPy is installed in /usr/local/lib64/python2.5/site-packages/scipy
 Python version 2.5.2 (r252:60911, Aug  1 2008, 00:37:21) [GCC 4.3.1
 20080507 (prerelease) [gcc-4_3-branch revision 135036]]
 nose version 0.10.3
 /usr/local/lib64/python2.5/site-packages/scipy/linsolve/__init__.py:4:
 DeprecationWarning: scipy.linsolve has moved to scipy.sparse.linalg.dsolve
   warn('scipy.linsolve has moved to scipy.sparse.linalg.dsolve',
 DeprecationWarning)
 [[ 0.55555556  0.6         0.3125      0.58333333  0.6         0.52
    0.63636364  0.44        0.5         0.52        0.38461538  0.42857143
    0.44        0.6         0.5         0.52        0.56521739  0.56521739
    0.41666667  0.52      ]
  [ 0.54545455  0.73333333  0.48148148  0.68421053  0.6         0.6
    0.64705882  0.8         0.68421053  0.5         0.52380952  0.47826087
    0.4         0.6         0.47368421  0.5         0.44444444  0.55555556
    0.68421053  0.5       ]
  [ 0.46153846  0.68421053  0.29032258  0.47826087  0.41666667  0.58333333
    0.52380952  0.33333333  0.56521739  0.5         0.28        0.40740741
    0.66666667  0.5         0.30434783  0.5         0.45454545  0.63636364
    0.39130435  0.66666667]
  [ 0.38461538  0.68421053  0.35483871  0.47826087  0.41666667  0.33333333
    0.42857143  0.25        0.39130435  0.5         0.6         0.40740741
    0.5         0.58333333  0.39130435  0.58333333  0.45454545  0.45454545
    0.73913043  0.33333333]
  [ 0.58333333  0.64705882  0.44827586  0.52380952  0.45454545  0.54545455
    0.57894737  0.54545455  0.61904762  0.63636364  0.47826087  0.44
    0.54545455  0.45454545  0.42857143  0.45454545  0.6         0.7
    0.33333333  0.45454545]
  [ 0.39130435  0.625       0.5         0.6         0.61904762  0.61904762
    0.66666667  0.52380952  0.6         0.61904762  0.36363636  0.5
    0.61904762  0.52380952  0.6         0.33333333  0.47368421  0.47368421
    0.5         0.71428571]
  [ 0.35714286  0.61904762  0.27272727  0.52        0.46153846  0.38461538
    0.56521739  0.46153846  0.52        0.61538462  0.48148148  0.37931034
    0.38461538  0.61538462  0.52        0.53846154  0.58333333  0.5
 0.36
    0.23076923]
  [ 0.30769231  0.57894737  0.35483871  0.56521739  0.33333333  0.58333333
    0.52380952  0.5         0.56521739  0.58333333  0.28        0.25925926
    0.41666667  0.5         0.47826087  0.41666667  0.54545455  0.54545455
    0.39130435  0.58333333]
  [ 0.45454545  0.73333333  0.40740741  0.57894737  0.8         0.6
    0.88235294  0.9         0.78947368  0.6         0.52380952  0.65217391
    0.6         0.7         0.68421053  0.7         0.77777778  0.77777778
    0.68421053  0.4       ]
  [ 0.46153846  0.68421053  0.35483871  0.47826087  0.5         0.41666667
    0.52380952  0.5         0.39130435  0.41666667  0.52        0.33333333
    0.5         0.5         0.47826087  0.41666667  0.54545455  0.45454545
    0.65217391  0.41666667]] [[ 0.55555556  0.6         0.3125
 0.58333333  0.6         0.52
    0.63636364  0.44        0.5         0.52        0.38461538  0.42857143
    0.44        0.6         0.5         0.52        0.56521739  0.56521739
    0.41666667  0.52      ]
  [ 0.54545455  0.73333333  0.48148148  0.68421053  0.6         0.6
    0.64705882  0.8         0.68421053  0.5         0.52380952  0.47826087
    0.4         0.6         0.47368421  0.5         0.44444444  0.55555556
    0.68421053  0.5       ]
  [ 0.46153846  0.68421053  0.29032258  0.47826087  0.41666667  0.58333333
    0.52380952  0.33333333  0.56521739  0.5         0.28        0.40740741
    0.66666667  0.5         0.30434783  0.5         0.45454545  0.63636364
    0.39130435  0.66666667]
  [ 0.38461538  0.68421053  0.35483871  0.47826087  0.41666667  0.33333333
    0.42857143  0.25        0.39130435  0.5         0.6         0.40740741
    0.5         0.58333333  0.39130435  0.58333333  0.45454545  0.45454545
    0.73913043  0.33333333]
  [ 0.58333333  0.64705882  0.44827586  0.52380952  0.45454545  0.54545455
    0.57894737  0.54545455  0.61904762  0.63636364  0.47826087  0.44
    0.54545455  0.45454545  0.42857143  0.45454545  0.6         0.7
    0.33333333  0.45454545]
  [ 0.39130435  0.625       0.5         0.6         0.61904762  0.61904762
    0.66666667  0.52380952  0.6         0.61904762  0.36363636  0.5
    0.61904762  0.52380952  0.6         0.33333333  0.47368421  0.47368421
    0.5         0.71428571]
  [ 0.35714286  0.61904762  0.27272727  0.52        0.46153846  0.38461538
    0.56521739  0.46153846  0.52        0.61538462  0.48148148  0.37931034
    0.38461538  0.61538462  0.52        0.53846154  0.58333333  0.5
 0.36
    0.23076923]
  [ 0.30769231  0.57894737  0.35483871  0.56521739  0.33333333  0.58333333
    0.52380952  0.5         0.56521739  0.58333333  0.28        0.25925926
    0.41666667  0.5         0.47826087  0.41666667  0.54545455  0.54545455
    0.39130435  0.58333333]
  [ 0.45454545  0.73333333  0.40740741  0.57894737  0.8         0.6
    0.88235294  0.9         0.78947368  0.6         0.52380952  0.65217391
    0.6         0.7         0.68421053  0.7         0.77777778  0.77777778
    0.68421053  0.4       ]
  [ 0.46153846  0.68421053  0.35483871  0.47826087  0.5         0.41666667
    0.52380952  0.5         0.39130435  0.41666667  0.52        0.33333333
    0.5         0.5         0.47826087  0.41666667  0.54545455  0.45454545
    0.65217391  0.41666667]]
 0.0
 .0.0
 .0.0
 .0.0
 .4.4408920985e-16
 .4.4408920985e-16
 .0.0
 .4.4408920985e-16
 .0.0
 .0.0
 .0.0
 .0.0
 .0.0
 .2.6645352591e-15
 .0.0
 .0.0
 .0.0
 .0.0
 .0.0
 .0.0
 .0.0
 .0.0
 .0.0
 .8.881784197e-16
 .0.0
 ....................................................................................................../usr/local/lib64/python2.5
 /site-packages/scipy/cluster/vq.py:570: UserWarning: One of the clusters
 is empty. Re-run kmean with a different initialization.
   warnings.warn("One of the clusters is empty. "
 .................................................E/usr/local/lib64/python2.5
 /site-packages/scipy/integrate/quadpack.py:306: DeprecationWarning:
 PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qawse(func,a,b,wvar,integr,args,full_output,epsabs,epsrel,limit)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:306:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qawse(func,a,b,wvar,integr,args,full_output,epsabs,epsrel,limit)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:308:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qawce(func,a,b,wvar,args,full_output,epsabs,epsrel,limit)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:308:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qawce(func,a,b,wvar,args,full_output,epsabs,epsrel,limit)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:297:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qawfe(thefunc,-b,wvar,integr,args,full_output,epsabs,limlst,limit,maxp1)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:297:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qawfe(thefunc,-b,wvar,integr,args,full_output,epsabs,limlst,limit,maxp1)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:251:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return _quadpack._qagse(func,a,b,args,full_output,epsabs,epsrel,limit)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:251:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return _quadpack._qagse(func,a,b,args,full_output,epsabs,epsrel,limit)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:253:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qagie(func,bound,infbounds,args,full_output,epsabs,epsrel,limit)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:253:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qagie(func,bound,infbounds,args,full_output,epsabs,epsrel,limit)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:275:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qawoe(func,a,b,wvar,integr,args,full_output,epsabs,epsrel,limit,maxp1,1)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:275:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qawoe(func,a,b,wvar,integr,args,full_output,epsabs,epsrel,limit,maxp1,1)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:282:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qawfe(func,a,wvar,integr,args,full_output,epsabs,limlst,limit,maxp1)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:282:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qawfe(func,a,wvar,integr,args,full_output,epsabs,limlst,limit,maxp1)
 ./usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:261:
 DeprecationWarning: PyArray_FromDims: use PyArray_SimpleNew.
   return
 _quadpack._qagpe(func,a,b,the_points,args,full_output,epsabs,epsrel,limit)
 /usr/local/lib64/python2.5/site-packages/scipy/integrate/quadpack.py:261:
 DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use
 PyArray_NewFromDescr.
   return
 _quadpack._qagpe(func,a,b,the_points,args,full_output,epsabs,epsrel,limit)
 ......E................................/usr/local/lib64/python2.5/site-
 packages/scipy/io/tests/test_array_import.py:29: DeprecationWarning:
 PyArray_FromDims: use PyArray_SimpleNew.
   b = numpyio.fread(fid,1000000,N.Int16,N.Int)
 /usr/local/lib64/python2.5/site-
 packages/scipy/io/tests/test_array_import.py:29: DeprecationWarning:
 PyArray_FromDimsAndDataAndDescr: use PyArray_NewFromDescr.
   b = numpyio.fread(fid,1000000,N.Int16,N.Int)
 Warning: 1000000 bytes requested, 20 bytes read.
 ./usr/local/lib64/python2.5/site-packages/numpy/lib/utils.py:106:
 DeprecationWarning: write_array is deprecated
   warnings.warn(str1, DeprecationWarning)
 /usr/local/lib64/python2.5/site-packages/numpy/lib/utils.py:106:
 DeprecationWarning: read_array is deprecated
   warnings.warn(str1, DeprecationWarning)
 ..E.................../usr/local/lib64/python2.5/site-
 packages/numpy/lib/utils.py:106: DeprecationWarning: npfile is deprecated
   warnings.warn(str1, DeprecationWarning)
 ......................Illegal instruction
 }}}

-- 
Ticket URL: <http://scipy.org/scipy/scipy/ticket/738>
SciPy <http://www.scipy.org/>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list