[Scipy-tickets] [SciPy] #729: SciPy not compatible with python -OO

SciPy scipy-tickets@scipy....
Wed Jan 28 04:01:48 CST 2009


#729: SciPy not compatible with python -OO
---------------------------+------------------------------------------------
 Reporter:  alan.mcintyre  |        Owner:  somebody
     Type:  defect         |       Status:  new     
 Priority:  normal         |    Milestone:  0.7.0   
Component:  Other          |      Version:          
 Severity:  normal         |   Resolution:          
 Keywords:                 |  
---------------------------+------------------------------------------------
Comment (by wr):

 In my case I have even problems to import it:
 {{{
  wr@[kagu]:~> python -c "import scipy; print scipy.__version__"
 0.6.0

  wr@[kagu]:~> python -O -c "import scipy"

  wr@[kagu]:~> python -OO -c "import scipy"
 Traceback (most recent call last):
   File "<string>", line 1, in <module>
   File "/usr/lib/python2.5/site-packages/scipy/__init__.py", line 25, in
 <module>
     from numpy import show_config as show_numpy_config
   File "/usr/lib/python2.5/site-packages/numpy/__init__.py", line 93, in
 <module>
     import add_newdocs
   File "/usr/lib/python2.5/site-packages/numpy/add_newdocs.py", line 9, in
 <module>
     from lib import add_newdoc
   File "/usr/lib/python2.5/site-packages/numpy/lib/__init__.py", line 19,
 in <module>
     from financial import *
   File "/usr/lib/python2.5/site-packages/numpy/lib/financial.py", line 78,
 in <module>
     """
 TypeError: unsupported operand type(s) for +=: 'NoneType' and 'str'

 }}}

-- 
Ticket URL: <http://www.scipy.org/scipy/scipy/ticket/729#comment:1>
SciPy <http://www.scipy.org/>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list