[Scipy-tickets] [SciPy] #1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

SciPy Trac scipy-tickets@scipy....
Wed Dec 8 07:10:34 CST 2010


#1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension
'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler
found
---------------------------+------------------------------------------------
  Reporter:  Valene        |       Owner:  cdavid
      Type:  defect        |      Status:  closed
  Priority:  high          |   Milestone:  0.9.0 
 Component:  Build issues  |     Version:  0.8.0 
Resolution:  fixed         |    Keywords:        
---------------------------+------------------------------------------------
Changes (by rgommers):

  * status:  needs_info => closed
  * resolution:  => fixed


Comment:

 I'm not familiar with pypar, and the setup.py source does not look very
 confidence-inspiring. I've seen mpi4py used much more often:
 http://mpi4py.scipy.org/docs/usrman/index.html

 If you need pypar I guess you have to try and install mpicc
 (http://linux.die.net/man/1/mpicc) or remove the call to it from setup.py
 and figure out the right flags by yourself. The popen2 warning is
 harmless.

 Since your original issue is now completely solved I'll close this ticket.
 For more questions you can also use the distutils or scipy-user lists.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1331#comment:21>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list