[Scipy-tickets] [SciPy] #709: ValueError: array dimensions are not compatible for copy

SciPy Trac scipy-tickets@scipy....
Sat Dec 11 15:14:31 CST 2010


#709: ValueError: array dimensions are not compatible for copy
---------------------------+------------------------------------------------
  Reporter:  nils          |       Owner:  somebody
      Type:  defect        |      Status:  closed  
  Priority:  high          |   Milestone:  0.10.0  
 Component:  scipy.linalg  |     Version:  devel   
Resolution:  fixed         |    Keywords:          
---------------------------+------------------------------------------------
Changes (by pv):

  * status:  needs_decision => closed
  * resolution:  => fixed
  * milestone:  0.9.0 => 0.10.0


Comment:

 This is a bug in LAPACK, but I nevertheless added a workaround for it in
 r7002, as the LAPACK guys don't seem to be in a hurry to fix it -- the bug
 is somehow related to which optimization flags LAPACK is compiled with.

 (The old implementation of `_make_complex_eigvecs` was also a bit wonky,
 and it makes sense to clean it up at the same time.)

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/709#comment:12>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list