[Scipy-tickets] [SciPy] #1094: Build succeeds but "from scipy import integrate" fails

SciPy Trac scipy-tickets@scipy....
Mon Jan 18 10:51:30 CST 2010


#1094: Build succeeds but "from scipy import integrate" fails
------------------------------+---------------------------------------------
 Reporter:  lebigot           |       Owner:  somebody
     Type:  defect            |      Status:  new     
 Priority:  normal            |   Milestone:  0.8.0   
Component:  scipy.integrate   |     Version:  devel   
 Keywords:  Symbol not found  |  
------------------------------+---------------------------------------------
 Numpy 1.5.0.dev8073 and Scipy 0.8.0.dev6208 build with no error on my
 (PPC) machine with Mac OS X 10.4.11.

 However, "from scipy import integrate" fails with:

 {{{
 ---------------------------------------------------------------------------
 ImportError                               Traceback (most recent call
 last)

 /Users/lebigot/<ipython console> in <module>()

 /sw/lib/python2.6/site-packages/scipy/integrate/__init__.py in <module>()
       7 from info import __doc__
       8
 ----> 9 from quadrature import *
      10 from odepack import *
      11 from quadpack import *

 /sw/lib/python2.6/site-packages/scipy/integrate/quadrature.py in
 <module>()
       3            'cumtrapz','newton_cotes','composite']
       4
 ----> 5 from scipy.special.orthogonal import p_roots
       6 from scipy.special import gammaln
       7 from numpy import sum, ones, add, diff, isinf, isscalar, \

 /sw/lib/python2.6/site-packages/scipy/special/__init__.py in <module>()
       6 #from special_version import special_version as __version__

       7
 ----> 8 from basic import *
       9 import specfun
      10 import orthogonal

 /sw/lib/python2.6/site-packages/scipy/special/basic.py in <module>()
       6
       7 from numpy import *
 ----> 8 from _cephes import *
       9 import types
      10 import specfun

 ImportError: dlopen(/sw/lib/python2.6/site-
 packages/scipy/special/_cephes.so, 2): Symbol not found: _e_wsle
   Referenced from: /sw/lib/python2.6/site-
 packages/scipy/special/_cephes.so
   Expected in: dynamic lookup
 }}}

 The compilation was done with (I use gcc 4.x):
 {{
 python setup.py build --fcompiler=gnu95
 }}
 I also tried:
 {{
 python setup.py build_ext --fcompiler=gnu95 -lSystemStubs
 }}
 to no avail.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1094>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list