[Scipy-tickets] [SciPy] #1180: scipy-0.7.2 does not build with python-2.7

SciPy Trac scipy-tickets@scipy....
Tue Jul 6 10:11:24 CDT 2010


#1180: scipy-0.7.2 does not build with python-2.7
--------------------------+-------------------------------------------------
 Reporter:  bicatali      |       Owner:  cdavid
     Type:  defect        |      Status:  new   
 Priority:  normal        |   Milestone:  0.8.0 
Component:  Build issues  |     Version:  0.7.0 
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by rgommers):

 Tried out the final Python 2.7 release. There are actually two OS X
 binaries provided:

   - The current 32-bit only installer that runs on OSX 10.3 or later
   - An installer that supports ppc, x86 and x86_64 and requires OSX 10.5
 or later

 I figured the 10.5 one needs numpy.distutils changes due to the x86_64
 support but the 10.3 one should be the same. I figured wrong. Even though
 the binary does not support x86_64, distutils changes still cause -arch
 x86_64 and even -arch ppc64 (the latter is not supported in either 2.7
 binary) to be passed to the scipy build. This happens only for Fortran, C
 code looks fine - which is why numpy does build fine.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1180#comment:6>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list