[Scipy-tickets] [SciPy] #1237: Ndimage for Python 3.1

SciPy Trac scipy-tickets@scipy....
Sat Jul 17 12:42:23 CDT 2010


#1237: Ndimage for Python 3.1
---------------------------+------------------------------------------------
 Reporter:  cjgohlke       |       Owner:  somebody    
     Type:  enhancement    |      Status:  needs_review
 Priority:  normal         |   Milestone:  0.9.0       
Component:  scipy.ndimage  |     Version:  devel       
 Keywords:                 |  
---------------------------+------------------------------------------------

Comment(by charris):

 PyCapsule was used in Python 2.7 because it was originally deprecated. Now
 that it is only a pending deprecation we can go back to using PyCObject.
 However, Pauli has made npy_3kcompat.h a public include file and I expect
 he will use the NpyCapsule wrappers it provides in SciPY. PyCapsule is the
 only thing available in Python >= 3.2.

 A separate patch cleaning up the code is welcome.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1237#comment:5>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list