[Scipy-tickets] [SciPy] #1177: OS X installer does not detect system python26 on Snow Leopard

SciPy Trac scipy-tickets@scipy....
Tue Jun 1 10:27:53 CDT 2010


#1177: OS X installer does not detect system python26 on Snow Leopard
--------------------------------+-------------------------------------------
  Reporter:  kalleh             |       Owner:  somebody                          
      Type:  defect             |      Status:  closed                            
  Priority:  normal             |   Milestone:  0.7.2                             
 Component:  Official binaries  |     Version:  0.7.0                             
Resolution:  fixed              |    Keywords:  Apple OS X Snow Leopard Python 2.6
--------------------------------+-------------------------------------------
Changes (by rgommers):

  * status:  reopened => closed
  * resolution:  => fixed


Comment:

 You're right, this message is quite unhelpful. I added a note to
 http://scipy.org/Download to explain.

 The message in the installer comes from the python_requirement function in
 plist.py in the bdist_mpkg package. Adding in the following will make
 things more clear:
 {{{
     # System python can be interpreted as Apple Python, explain this
 better
     if name.startswith('System Python'):
         title = u'%s requires %s from www.python.org to install.' %
 (pkgname,
 name[7:],)
     else:
         title = u'%s requires %s to install.' % (pkgname, name,)
 }}}

 It's a pain though to keep a patched version of bdist_mpkg around just for
 this, so I'll email the author. I applied the change on my local version
 of it, but that may get lost again at some point.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1177#comment:3>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list