[Scipy-tickets] [SciPy] #1332: python setup.py install /usr/bin/ld: cannot find -lnpymath

SciPy Trac scipy-tickets@scipy....
Tue Nov 23 20:05:19 CST 2010


#1332: python setup.py install /usr/bin/ld: cannot find -lnpymath
---------------------------+------------------------------------------------
  Reporter:  peterwt       |       Owner:  cdavid                      
      Type:  defect        |      Status:  closed                      
  Priority:  high          |   Milestone:  0.9.0                       
 Component:  Build issues  |     Version:  0.8.0                       
Resolution:  invalid       |    Keywords:  lnpymath, optimize.curve_fit
---------------------------+------------------------------------------------

Comment(by peterwt):

 don't know if it matters but, the build errors above result from
 attempting to build using the scipy-0.8.0.tar.gz archive (sourceforge) not
 the debian package. Installing using the Debian package works fine, that
 version just doesn't seen to have optimize.curve_fit .

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1332#comment:3>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list