[Scipy-tickets] [SciPy] #1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

SciPy Trac scipy-tickets@scipy....
Mon Nov 29 10:20:09 CST 2010


#1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension
'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler
found
--------------------------+-------------------------------------------------
 Reporter:  Valene        |       Owner:  cdavid
     Type:  defect        |      Status:  new   
 Priority:  high          |   Milestone:  0.9.0 
Component:  Build issues  |     Version:  0.8.0 
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by rgommers):

 You're using gfortran, so you should be specifying --fcompiler=gnu instead
 of =g95. Does that fix the issue?

 You do have an uncommented version_pattern:
 {{{
 version_pattern = r'G95 \((GCC (?P<gccversion>[\d.]+)|.*?) \(g95
 }}}
 which clearly doesn't match. =gnu should fix it, but otherwise you can
 modify the v-string to match.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1331#comment:9>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list