[Scipy-tickets] [SciPy] #1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

SciPy Trac scipy-tickets@scipy....
Mon Nov 29 11:22:08 CST 2010


#1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension
'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler
found
--------------------------+-------------------------------------------------
 Reporter:  Valene        |       Owner:  cdavid
     Type:  defect        |      Status:  new   
 Priority:  high          |   Milestone:  0.9.0 
Component:  Build issues  |     Version:  0.8.0 
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by Valene):

 Ok ...
 I obtained something like that :
 /opt/cray/xt-asyncpe/3.6/bin/f77: INFO: linux target is being used
 GCC 4.4.2 does not support f77.
 You may alias f77 to ftn, but GNU does not provide a g77
 interface with gcc 4.0 and beyond. Also, there may be some
 problems with conflicts of entry point names.
 ar: adding 23 object files to build/temp.linux-x86_64-2.6/libdfftpack.a
 ar: build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcosqb.o: No
 such file or directory
 ar: build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcosqb.o: No
 such file or directory
 error: Command "ar -cr build/temp.linux-x86_64-2.6/libdfftpack.a
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcosqb.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcosqf.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcosqi.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcost.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dcosti.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dfftb.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dfftb1.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dfftf.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dfftf1.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dffti.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dffti1.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dsinqb.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dsinqf.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dsinqi.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dsint.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dsint1.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/dsinti.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/zfftb.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/zfftb1.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/zfftf.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/zfftf1.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/zffti.o
 build/temp.linux-x86_64-2.6/scipy/fftpack/src/dfftpack/zffti1.o" failed
 with exit status 1

 I guess I have to downgrade the version of gnu compilers, is that right ?

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1331#comment:11>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list