[Scipy-tickets] [SciPy] #1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

SciPy Trac scipy-tickets@scipy....
Tue Nov 30 09:39:01 CST 2010


#1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension
'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler
found
--------------------------+-------------------------------------------------
 Reporter:  Valene        |       Owner:  cdavid    
     Type:  defect        |      Status:  needs_info
 Priority:  high          |   Milestone:  0.9.0     
Component:  Build issues  |     Version:  0.8.0     
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by Valene):

 This time, I "alias"ed f77, g77 and gfortran to ftn. I exported F77 F90
 and FC to ftn.
 During the build/installation, I have some compilation lines like that :
 ftn:f77: scipy/fftpack/src/dfftpack/dcosqb.f
 This confuses me about which compiler it's actually using.

 I still finishes with the same error :
 warning: build_ext: f77_compiler=gnu is not available.
 building 'scipy.interpolate.dfitpack' extension
 error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no
 Fortran compiler found.

 I attached the log in the scipy_log2.

 Thanks

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1331#comment:14>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list