[Scipy-tickets] [SciPy] #1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

SciPy Trac scipy-tickets@scipy....
Tue Nov 30 10:57:57 CST 2010


#1331: Scipy on Cray XT when cross-compiling with gnu compilers : error: extension
'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler
found
--------------------------+-------------------------------------------------
 Reporter:  Valene        |       Owner:  cdavid    
     Type:  defect        |      Status:  needs_info
 Priority:  high          |   Milestone:  0.9.0     
Component:  Build issues  |     Version:  0.8.0     
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by rgommers):

 First remark: I' not sure if there a specific problem on Cray, see the
 PrgEnv module stuff above. But OK, let's go back to the beginning.

 Q1: the default compiler on on anything but Windows is gfortran. What
 happens if you leave out all the config options, only alias gfortran to
 ftn (not g77 or f77) and then do plain
 {{{
 $ python setup.py install
 }}}

 Q2: Does this work better (=gnu95 works for me, =gnu does not):
 {{{
 python setup.py config_fc --fcompiler=gnu95 build_clib --fcompiler=gnu95
 build_ext --fcompiler=gnu95 build
 }}}
 This is due to the version string stuff, which admittedly is a bit insane.
 See attached file test_gnu_version.py

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1331#comment:15>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list