[Scipy-tickets] [SciPy] #1238: Numpy.mod fails after call to scipy.lib.lapack.flapack.dsyevr

SciPy Trac scipy-tickets@scipy....
Sat Sep 4 21:49:10 CDT 2010


#1238: Numpy.mod fails after call to scipy.lib.lapack.flapack.dsyevr
-----------------------+----------------------------------------------------
 Reporter:  cjgohlke   |       Owner:  somebody  
     Type:  defect     |      Status:  needs_info
 Priority:  normal     |   Milestone:  0.9.0     
Component:  scipy.lib  |     Version:  0.7.0     
 Keywords:             |  
-----------------------+----------------------------------------------------

Comment(by cjgohlke):

 It is likely a 64 bit MKL issue.

 The failure is also present using the latest 64-bit versions (Python 2.7,
 numpy 1.5.0, scipy 0.8, MKL 10.2.6.1), EPD 6.2-2 64-bit for Windows, and
 probably (unconfirmed) the enterprise distribution of ActivePython, which
 also uses MKL.

 Numpy 1.5.0 prints a warning during the first numpy.mod call after calling
 dsyevr:
 {{{
 >>> dsyevr(numpy.array([[1,2,3],[2,2,3],[3,3,6]]))
 (array([-0.66992434,  0.48769389,  9.18223045]), array([[ 0.87881028,
 -0.25679224,  0.40218185],
        [-0.432995  , -0.78333614,  0.44598186],
        [-0.20051889,  0.56607617,  0.79959361]]), 0)
 >>> numpy.mod(1., 1)
 Warning: invalid value encountered in remainder
 nan
 }}}

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1238#comment:3>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list