[Scipy-tickets] [SciPy] #1429: pip install fails

SciPy Trac scipy-tickets@scipy....
Thu Apr 28 16:44:04 CDT 2011


#1429: pip install fails
--------------------------+-------------------------------------------------
 Reporter:  ready.eddy    |       Owner:  cdavid
     Type:  defect        |      Status:  new   
 Priority:  normal        |   Milestone:        
Component:  Build issues  |     Version:  0.9.0 
 Keywords:                |  
--------------------------+-------------------------------------------------
 I have been trying to get scipy to install using pip [http://www.pip-
 installer.org/].

 I would like to be able to install from a requirements file that includes
 both numpy and scipy. Unfortunately this fails, as pip trys to run scipy
 before numpy is installed. In the scipy setup file are the imports:

 {{{
   from numpy.distutils.misc_util import Configuration
   from numpy.distutils.core import setup
 }}}


 Would it be possible to avoid using these numpy modules in setup.py? This
 would make the setup process more robust

 For more discussion of the issue on the pip tracking system see:

 [https://github.com/pypa/pip/issues/25]

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1429>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list