[Scipy-tickets] [SciPy] #1321: scipy.sparse.linalg.isolve depends on cdotc and zdotc, which require wrappers on Mac OS X

SciPy Trac scipy-tickets@scipy....
Thu Aug 18 14:57:31 CDT 2011


#1321: scipy.sparse.linalg.isolve depends on cdotc and zdotc, which require
wrappers on Mac OS X
-----------------------------------------------------------------+----------
 Reporter:  commandant2k                                         |       Owner:  wnbell
     Type:  defect                                               |      Status:  new   
 Priority:  high                                                 |   Milestone:  0.10.0
Component:  scipy.sparse.linalg                                  |     Version:  devel 
 Keywords:  BLAS, Accelerate, iterative, cdotc, zdotc, Mac OS X  |  
-----------------------------------------------------------------+----------
Changes (by pv):

  * priority:  normal => high
  * milestone:  Unscheduled => 0.10.0


Comment:

 The patch looks OK to me -- don't have a OSX at hand, so couldn't test it.
 Some code duplication with the stuff in ARPACK, but not too bad. The
 veclib_cabi_c.c.src however needs a `#include <complex.h>` on the top.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1321#comment:1>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list