[Scipy-tickets] [SciPy] #1376: SciPy 0.9 rc1 does not build with msvc9, ifort, MKL

SciPy Trac scipy-tickets@scipy....
Fri Jan 28 18:56:41 CST 2011


#1376: SciPy 0.9 rc1 does not build with msvc9, ifort, MKL
----------------------+-----------------------------------------------------
 Reporter:  cjgohlke  |       Owner:  somebody
     Type:  defect    |      Status:  new     
 Priority:  normal    |   Milestone:  0.9.0   
Component:  Other     |     Version:  0.8.0   
 Keywords:            |  
----------------------+-----------------------------------------------------
 Some build issues reported at <http://mail.scipy.org/pipermail/scipy-
 dev/2010-September/015535.html> and <http://mail.scipy.org/pipermail
 /scipy-dev/2010-December/015813.html> remain. A revised patch for scipy
 0.9 rc1 is attached.

 Atlas_version.c needs 'NO_ATLAS_INFO' defined when using MKL on Windows.
 The patch uses "define_macros = [('NO_ATLAS_INFO', 1)]" in setup.py.

 'lsame.c' needs to be removed from the SuperLU source files in
 scipy/sparse/linalg/dsolve/setup.py. lsame is provided by MKL.

 Scipy/optimize/lbfgsb/routines.f and
 scipy/sparse/linalg/eigen/arpack/ARPACK/UTIL/second.f use the etime
 function, which can not be resolved even though libifportmd is linked. The
 patch uses CPU_TIME. I'm not sure this is portable.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1376>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list