[Scipy-tickets] [SciPy] #1476: easy_install of 0.9.0 fails on OS X 10.7 (Lion)

SciPy Trac scipy-tickets@scipy....
Tue Jul 12 22:12:38 CDT 2011


#1476: easy_install of 0.9.0 fails on OS X 10.7 (Lion)
--------------------------+-------------------------------------------------
 Reporter:  tacoe         |       Owner:  cdavid     
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  0.9.0      
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by cax):

 I also have tried to build on Lion with no luck. In my case the problem is
 when trying to compile
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c.

 Python is installed via homebrew.

 Log:

 C compiler: /usr/bin/cc -fno-strict-aliasing -O3 -march=core2 -msse4.1 -w
 -pipe -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes

 compile options: '-Iscipy/sparse/linalg/eigen/arpack/ARPACK/SRC
 -I/usr/local/Cellar/python/2.7.2/lib/python2.7/site-
 packages/numpy/core/include -c'
 cc: scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:4:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘float’
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:10:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘float’
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:16:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:21:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:4:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘float’
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:10:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘float’
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:16:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:21:
 error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
 error: Command "/usr/bin/cc -fno-strict-aliasing -O3 -march=core2 -msse4.1
 -w -pipe -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes
 -Iscipy/sparse/linalg/eigen/arpack/ARPACK/SRC
 -I/usr/local/Cellar/python/2.7.2/lib/python2.7/site-
 packages/numpy/core/include -c
 scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c -o
 build/temp.macosx-10.4-x86_64-2.7/scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.o"
 failed with exit status 1

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1476#comment:3>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list