[Scipy-tickets] [SciPy] #1476: easy_install of 0.9.0 fails on OS X 10.7 (Lion)

SciPy Trac scipy-tickets@scipy....
Sat Jul 23 13:35:48 CDT 2011


#1476: easy_install of 0.9.0 fails on OS X 10.7 (Lion)
--------------------------+-------------------------------------------------
 Reporter:  tacoe         |       Owner:  cdavid     
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  0.9.0      
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by rsenk330):

 I can get this to install using gfortran from homebrew. I had to use the
 gfortran formula from a testing repository until it gets pushed to the
 master. Instructions can be found on this
 [https://github.com/mxcl/homebrew/issues/6500#issuecomment-1637840
 homebrew ticket].

 I also had to add {{{#include <complex.h>}}} to the top of the following
 files:

  * scipy/linalg/src/fblaswrap_veclib_c.c
  * scipy/lib/blas/fblaswrap_veclib_c.c.src
  * scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1476#comment:20>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list