[Scipy-tickets] [SciPy] #1512: OS X Lion: FAIL: test_mio_utils.test_squeeze_element(False, )

SciPy Trac scipy-tickets@scipy....
Wed Sep 7 07:11:14 CDT 2011


#1512: OS X Lion: FAIL: test_mio_utils.test_squeeze_element(False,)
---------------------------------------------+------------------------------
 Reporter:  samuel                           |       Owner:  somebody
     Type:  defect                           |      Status:  new     
 Priority:  normal                           |   Milestone:  0.9.1   
Component:  Other                            |     Version:  devel   
 Keywords:  Mac, OSX, Lion, FAIL, test, mio  |  
---------------------------------------------+------------------------------
 On 10.7.1 OS X Lion, SciPy version 0.10.0.dev fails two tests. One is:

 '''FAIL: test_mio_utils.test_squeeze_element(False,)'''

 Here are the details:
 Built scipy/numpy with

 {{{
 export FFLAGS=-ff2c
 export CC=gcc-4.2
 export CXX=g++-4.2
 python setup.py build --fcompiler=gfortran
 python setup.py install
 }}}

 {{{
 Python 2.7.2 (default, Sep  5 2011, 10:50:07)
 Type "copyright", "credits" or "license" for more information.

 IPython 0.11 -- An enhanced Interactive Python.
 ?         -> Introduction and overview of IPython's features.
 %quickref -> Quick reference.
 help      -> Python's own help system.
 object?   -> Details about 'object', use 'object??' for extra details.

 In [1]: import scipy

 In [2]: scipy.test()
 Running unit tests for scipy
 NumPy version 2.0.0.dev-900d82e
 NumPy is installed in
 /usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/numpy
 SciPy version 0.10.0.dev
 SciPy is installed in
 /usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy
 Python version 2.7.2 (default, Sep  5 2011, 10:50:07) [GCC 4.2.1 (Based on
 Apple Inc. build 5658) (LLVM build 2335.15.00)]
 nose version 1.1.2
 ............................................................................................................................................................................................................................K............................................................................................................/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/interpolate/fitpack2.py:674: UserWarning:
 The coefficients of the spline returned have been computed as the
 minimal norm least-squares solution of a (numerically) rank deficient
 system (deficiency=7). If deficiency is large, the results may be
 inaccurate. Deficiency may strongly depend on the value of eps.
   warnings.warn(message)
 ....../usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/interpolate/fitpack2.py:605: UserWarning:
 The required storage space exceeds the available storage space: nxest
 or nyest too small, or s too small.
 The weighted least-squares spline corresponds to the current set of
 knots.
   warnings.warn(message)
 ........................K..K....../usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/numpy/core/numeric.py:2020: RuntimeWarning: invalid value
 encountered in absolute
   return all(less_equal(absolute(x-y), atol + rtol * absolute(y)))
 ..........................................................................................................................................................................................................................................................F............................................................................................................................................................................./usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/io/wavfile.py:31: WavFileWarning: Unfamiliar format
 bytes
   warnings.warn("Unfamiliar format bytes", WavFileWarning)
 /usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/io/wavfile.py:121: WavFileWarning: chunk not
 understood
   warnings.warn("chunk not understood", WavFileWarning)
 ................................................................................./usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/numpy/lib/utils.py:139: DeprecationWarning:
 `get_blas_funcs` is deprecated!
   warnings.warn(depdoc, DeprecationWarning)
 ..............................................................................................................................................SSSSSS......SSSSSS......SSSS...............................................................................S............................................................................................................................................................................................................................................................K......................................................................................................................................................................................................SSSSS............S........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................SSSSSSSSSSS.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................K...............................................................K...........................................................................................................................................................KK.............................................................................................................................................................................................................................................................................................................................................................................................................................................K.K...........................................................................................................................................................................................................................................................................................................................................................................................K........K.........SSSSSSS..............................F....../usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/distributions.py:1258: DeprecationWarning:
 putmask has been deprecated. Use copyto with 'where' as the mask instead
   putmask(output,(1-cond0)*array(cond1,bool),self.badvalue)
 ./usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/distributions.py:1301: DeprecationWarning:
 putmask has been deprecated. Use copyto with 'where' as the mask instead
   putmask(output,(1-cond0)*array(cond1,bool),self.badvalue)
 .............................................................................................................................................................................................../usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/distributions.py:3249: DeprecationWarning:
 putmask has been deprecated. Use copyto with 'where' as the mask instead
   putmask(logpdf,(c==1) & (x==1),0.0) # logpdf(c==1 & x==1) = 0; % 0^0
 situation
 ........................................................................................................................................................./usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/distributions.py:4110: RuntimeWarning: overflow
 encountered in exp
   return exp(c*x-exp(x)-gamln(c))
 ................................./usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/distributions.py:4592: RuntimeWarning: invalid
 value encountered in sqrt
   vals = 2*(bt+1.0)*sqrt(b-2.0)/((b-3.0)*sqrt(b))
 .........................................................................................................................................................................................................................................................................................................S................................................................................................................................................................................................/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/distributions.py:5107: RuntimeWarning: divide
 by zero encountered in divide
   return where((lam <= 0) | (abs(x) < 1.0/arr(lam)), Px, 0.0)
 .......................................................................................................................................................................................................................................................................................................................................................................................................................
 ======================================================================
 FAIL: test_mio_utils.test_squeeze_element(False,)
 ----------------------------------------------------------------------
 Traceback (most recent call last):
   File
 "/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/nose/case.py", line 197, in runTest
     self.test(*self.arg)
 AssertionError: False is not true

 ======================================================================
 FAIL: Some very simple tests for chi2_contingency.
 ----------------------------------------------------------------------
 Traceback (most recent call last):
   File
 "/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/nose/case.py", line 197, in runTest
     self.test(*self.arg)
   File
 "/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/scipy/stats/tests/test_contingency.py", line 67, in
 test_chi2_contingency_trival
     assert_equal(p, 1.0)
   File
 "/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 /site-packages/numpy/testing/utils.py", line 300, in assert_equal
     raise AssertionError(msg)
 AssertionError:
 Items are not equal:
  ACTUAL: nan
  DESIRED: 1.0

 ----------------------------------------------------------------------
 Ran 5622 tests in 59.327s

 FAILED (KNOWNFAIL=12, SKIP=42, failures=2)
 Out[2]: <nose.result.TextTestResult run=5622 errors=0 failures=2>
 }}}

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1512>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list