[Scipy-tickets] [SciPy] #1500: Build issues with llvm-gcc on OS X 10.7 (Lion)

SciPy Trac scipy-tickets@scipy....
Thu Sep 8 02:37:21 CDT 2011


#1500: Build issues with llvm-gcc on OS X 10.7 (Lion)
--------------------------+-------------------------------------------------
 Reporter:  rgommers      |       Owner:  cdavid     
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  devel      
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by ludwig):

 Just thinking out loud (and maybe this is obvious)...

 Maybe this issue arises because the recommended gfortran for Lion at
 http://r.research.att.com/gfortran-lion-5666-3.pkg is itself built against
 gcc-4.2 instead of llvm-gcc-4.2, as can be seen in the following versions:

 gcc -v => gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build
 2335.15.00)
 llvm-gcc-4.2 -v => gcc version 4.2.1 (Based on Apple Inc. build 5658)
 (LLVM build 2335.15.00)
 gcc-4.2 -v => gcc version 4.2.1 (Apple Inc. build 5666) (dot 3)
 gfortran -v => gcc version 4.2.1 (Apple Inc. build 5666) (dot 3)

 Maybe we can persuade the kind R folks to build gfortran against llvm-
 gcc-4.2 as well (if this is at all possible).

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1500#comment:1>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list