[Scipy-tickets] [SciPy] #1314: import scipy.sparse.sparsetools causes consistent exit code 0

SciPy Trac scipy-tickets@scipy....
Tue Sep 20 17:06:38 CDT 2011


#1314: import scipy.sparse.sparsetools causes consistent exit code 0
---------------------------------------+------------------------------------
 Reporter:  markMiscavage              |       Owner:  wnbell     
     Type:  defect                     |      Status:  new        
 Priority:  normal                     |   Milestone:  Unscheduled
Component:  scipy.sparse               |     Version:  0.8.0      
 Keywords:  sparsetools exit code pyd  |  
---------------------------------------+------------------------------------

Comment(by steveDoyle):

 For the versions that I tested (on scipy 0.7.1, 0.8.0, and 0.9.0) this was
 the list of modules that I found to be a problem.

 {{{
 # SOMETIMES CAUSE BUG
 import scipy.optimize     # 0.9.0
 import scipy.linalg       # 0.7.1
 import scipy.interpolate  # 0.7.1, 0.9.0
 import scipy.signal       # 0.7.1, 0.9.0
 import scipy.stats        # 0.7.1, 0.9.0

 # ALWAYS CAUSE BUG - 0.7.1, 0.8.0, 0.9.0
 import scipy.cluster
 import scipy.io
 import scipy.maxentropy
 import scipy.sparse
 import scipy.spatial
 }}}
 I also traced each modules imports (in 0.9.0) and found all imports are
 good up until scipy.sparse is imported (except for scipy.interpolate,
 which I believe imported sparse.h from within the SWIG code).

 The offending python lines:
 {{{
 from csr import *   # scipy.sparse - line 3 in
 scipy/sparse/sparsetools/__init__.py

 from interpnd import LinearNDInterpolator, NDInterpolatorBase, \ #
 scipy.interpolate
      CloughTocher2DInterpolator, _ndim_coords_from_arrays        # line
 9,10 in scipy/interpolate/ndgriddata.py
 }}}

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1314#comment:8>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list