[Scipy-tickets] [SciPy] #1500: Build issues with llvm-gcc on OS X 10.7 (Lion)

SciPy Trac scipy-tickets@scipy....
Thu Jan 26 11:03:34 CST 2012


#1500: Build issues with llvm-gcc on OS X 10.7 (Lion)
--------------------------+-------------------------------------------------
 Reporter:  rgommers      |       Owner:  cdavid     
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  devel      
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by samuel):

 Yes, basically that is what I do in my homebrew formulate
 (https://github.com/samueljohn/homebrew-alt/blob/samuel/other/scipy.rb) in
 order to install scipy 0.10.0 (and the head revision, optional).

 It works by using the gfortran from r.research.att.com which can be
 installed with `brew install gfortran`.

 As you suggested, I use CC=gcc-4.2 ... , too!

 But the question is: Why does scipy not build with llvm-gcc? I consider
 `pip install scipy` to be broken on the Mac right now due to this issue -
 which is a shame.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1500#comment:8>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list