[Scipy-tickets] [SciPy] #1646: Could not find file error from setup.py build

SciPy Trac scipy-tickets@scipy....
Sun Jul 15 19:22:36 CDT 2012


#1646: Could not find file error from setup.py build
--------------------------+-------------------------------------------------
 Reporter:  bdpy          |       Owner:  somebody   
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  0.10.0     
 Keywords:                |  
--------------------------+-------------------------------------------------

Comment(by bohoro):

 Replying to [comment:5 rgommers]:
 > Hmm, this will take some debugging. Either we broke something,
 {{{easy_install}}} broke something, or it is somehow not possibly to mix a
 distutils scipy build with a setuptools-installed numpy.
 >
 > Do you use setuptools or distribute?
 >
 > Does {{{easy_install -U scipy}}} work for you?

 My apologies, prior to attempting to build from src I believe I had run
 the "ScipySuperpack" script which did not complete successfully.
 Unfortunately, I do not recall the details.  My primary scipy machines run
 linux where I had not had any issues.

 "easy_install -U scipy" did not appear to work as it complained and
 scipy.test() is still failing.

 Here is the output from easy_install:

 {{{
 Searching for scipy
 Reading http://pypi.python.org/simple/scipy/
 Reading http://www.scipy.org
 Reading
 http://sourceforge.net/project/showfiles.php?group_id=27747&package_id=19531
 Reading http://new.scipy.org/Wiki/Download
 Best match: scipy 0.10.1
 Downloading
 http://pypi.python.org/packages/source/s/scipy/scipy-0.10.1.zip#md5=4156cc1b765eb186de9518a94b6c3518
 Processing scipy-0.10.1.zip
 Running scipy-0.10.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-
 Mg29z6/scipy-0.10.1/egg-dist-tmp-nJW3cb
 Running from scipy source directory.
 non-existing path in '/private/tmp/easy_install-
 Mg29z6/scipy-0.10.1/scipy/io': 'docs'
 /Library/Python/2.7/site-
 packages/numpy-1.6.2-py2.7-macosx-10.7-intel.egg/numpy/distutils/system_info.py:470:
 UserWarning:
     UMFPACK sparse solver
 (http://www.cise.ufl.edu/research/sparse/umfpack/)
     not found. Directories to search for the libraries can be specified in
 the
     numpy/distutils/site.cfg file (section [umfpack]) or by setting
     the UMFPACK environment variable.
   warnings.warn(self.notfounderror.__doc__)
 error: None

 }}}

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1646#comment:6>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list