[Scipy-tickets] [SciPy] #1616: interpolate.sproot fails even when running fitpack tests

SciPy Trac scipy-tickets@scipy....
Sat Mar 3 19:28:27 CST 2012


#1616: interpolate.sproot fails even when running fitpack tests
-------------------------------+--------------------------------------------
 Reporter:  clopezx            |       Owner:  somebody   
     Type:  defect             |      Status:  new        
 Priority:  normal             |   Milestone:  Unscheduled
Component:  scipy.interpolate  |     Version:  0.10.0     
 Keywords:                     |  
-------------------------------+--------------------------------------------

Comment(by clopezx):

 Replying to [comment:7 pv]:
 > I can't reproduce the issue with the given test data. Attached is a test
 program, which is according to what you wrote. However, for me, `sproot`
 does not raise any errors. Does it raise an error for you? If not, can you
 attach a complete test program that reproduces the error?

 Yes, it raises ValueError as I posted before. I get this in Mac OS 10.7.3
 with scipy 0.11-dev

 In [22]: scipy.version
 Out[22]: <module 'scipy.version' from '/Library/Python/2.7/site-
 packages/scipy-0.11.0.dev_491f9db_20120228-py2.7-macosx-10.7-x86_64.egg/scipy/version.pyc'>

 Notice I ran the same code in an Ubuntu box with no problems. It seems to
 me it is a fitpack.so error...

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1616#comment:8>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list