[Scipy-tickets] [SciPy] #1739: Incompatibility with Python 3.3

SciPy Trac scipy-tickets@scipy....
Sat Oct 27 09:59:24 CDT 2012


#1739: Incompatibility with Python 3.3
----------------------+-----------------------------------------------------
 Reporter:  Arfrever  |       Owner:  somebody   
     Type:  defect    |      Status:  new        
 Priority:  normal    |   Milestone:  Unscheduled
Component:  Other     |     Version:  0.11.0     
 Keywords:            |  
----------------------+-----------------------------------------------------
Changes (by dkasak):

 * cc: denis.kasak@… (added)


Comment:

 This affects me as well. At least scipy.stats is also affected since
 that's where I encountered the bug.

 The first import gives me this:

 {{{
 >>> import scipy.stats
 Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
   File "/usr/lib/python3.3/site-packages/scipy/stats/__init__.py", line
 321, in <module>
     from .stats import *
   File "/usr/lib/python3.3/site-packages/scipy/stats/stats.py", line 194,
 in <module>
     import scipy.special as special
   File "/usr/lib/python3.3/site-packages/scipy/special/__init__.py", line
 532, in <module>
     from .lambertw import lambertw
   File "lambertw.pyx", line 24, in init scipy.special.lambertw
 (scipy/special/lambertw.c:1588)
 ValueError: level must be >= 0
 }}}


 If I try importing again, I get this:

 {{{
 >>> import scipy.stats
 Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
   File "/usr/lib/python3.3/site-packages/scipy/stats/__init__.py", line
 321, in <module>
     from .stats import *
   File "/usr/lib/python3.3/site-packages/scipy/stats/stats.py", line 194,
 in <module>
     import scipy.special as special
   File "/usr/lib/python3.3/site-packages/scipy/special/__init__.py", line
 528, in <module>
     from . import specfun
 ImportError: cannot import name specfun
 }}}


 Scipy version:

 {{{
 >>> scipy.version.full_version
 '0.11.0'
 >>> scipy.version.git_revision
 '827679b6f0149abb2c0e121749887012946b99c3'
 }}}


 Python version:

 {{{
 >>> sys.version
 '3.3.0 (default, Sep 29 2012, 15:50:43) \n[GCC 4.7.1 20120721
 (prerelease)]'
 }}}


 There's additional information on the
 [https://bugs.archlinux.org/task/32072 Arch Linux bug tracker].

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1739#comment:1>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list