[Scipy-tickets] [SciPy] #1739: Incompatibility with Python 3.3

SciPy Trac scipy-tickets@scipy....
Sun Sep 30 19:43:39 CDT 2012


#1739: Incompatibility with Python 3.3
----------------------+-----------------------------------------------------
 Reporter:  Arfrever  |       Owner:  somebody   
     Type:  defect    |      Status:  new        
 Priority:  normal    |   Milestone:  Unscheduled
Component:  Other     |     Version:  0.11.0     
 Keywords:            |  
----------------------+-----------------------------------------------------
 Test suite of SciPy 0.11.0 fails with segmentation fault with Python 3.3.

 Additionally some extension modules fail to import with Python 3.3.
 Example:
 {{{
 $ python3.3 -c 'import scipy.io'
 Traceback (most recent call last):
   File "<string>", line 1, in <module>
   File "/usr/lib64/python3.3/site-packages/scipy/io/__init__.py", line 83,
 in <module>
     from .matlab import loadmat, savemat, byteordercodes
   File "/usr/lib64/python3.3/site-packages/scipy/io/matlab/__init__.py",
 line 11, in <module>
     from .mio import loadmat, savemat
   File "/usr/lib64/python3.3/site-packages/scipy/io/matlab/mio.py", line
 15, in <module>
     from .mio4 import MatFile4Reader, MatFile4Writer
   File "/usr/lib64/python3.3/site-packages/scipy/io/matlab/mio4.py", line
 15, in <module>
     from .mio_utils import squeeze_element, chars_to_strings
   File "mio_utils.pyx", line 5, in init scipy.io.matlab.mio_utils
 (scipy/io/matlab/mio_utils.c:3848)
 ValueError: level must be >= 0
 }}}

 (I use NumPy 1.7.0 beta 2.)

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1739>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list