[Scipy-tickets] [SciPy] #1890: spsolve crash Python 3.2 on Linux 64, report Illegal instruction

SciPy Trac scipy-tickets@scipy....
Tue Apr 16 02:05:30 CDT 2013


#1890: spsolve crash Python 3.2 on Linux 64, report Illegal instruction
----------------------------------+-----------------------------------------
  Reporter:  davyzhu              |       Owner:  jakevdp    
      Type:  defect               |      Status:  reopened   
  Priority:  normal               |   Milestone:  Unscheduled
 Component:  scipy.sparse.linalg  |     Version:  0.12.0     
Resolution:                       |    Keywords:             
----------------------------------+-----------------------------------------

Comment(by pv):

 If the issue occurs with an Ubuntu-shipped BLAS binary that is supposed to
 be compatible with your CPU, it might be useful to let the Ubuntu package
 maintainers know about it. You can perhaps check using gdb what the
 offending instruction causing the crash is (I think the relevant gdb
 command is `x/i $pc`), and then check using `objdump` (see how the
 `detect_cpu_extensions` script does it) that the instruction is indeed
 present in the binary.

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1890#comment:6>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list