[Scipy-tickets] [SciPy] #1835: mpiexec with numpy causes segfault

SciPy Trac scipy-tickets@scipy....
Mon Feb 4 21:55:34 CST 2013


#1835: mpiexec with numpy causes segfault
-----------------------+----------------------------------------------------
 Reporter:  freechus9  |       Owner:  somebody    
     Type:  defect     |      Status:  needs_review
 Priority:  normal     |   Milestone:  Unscheduled 
Component:  Other      |     Version:  0.11.0      
 Keywords:             |  
-----------------------+----------------------------------------------------

Comment(by freechus9):

 More information, even more strange.

 So numpy is definitely broken somehow.  I directly copied over the numpy
 and egg-info from the working account to this one, and now it works fine.
 Somehow I must be installing numpy with an incorrect setting.

 Here is my site.cfg:


 {{{
 library_dirs = /home/freechus9/.local/lib
 include_dirs = /home/freechus9/.local/include

 [blas]
 blas_libs = openblas

 [lapack]
 lapack_libs = openblas

 [amd]
 amd_libs = amd

 [umfpack]
 umfpack_libs = umfpack
 }}}

 Then I just do


 {{{
 export ATLAS=None
 export BLAS=$HOME/.local/lib/libopenblas.so
 export LAPACK=$HOME/.local/lib/libopenblas.so

 python setup.py build

 python setup.py install --user
 }}}

 What can I be possibly doing wrong?

-- 
Ticket URL: <http://projects.scipy.org/scipy/ticket/1835#comment:5>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list