[SciPy-user] Installation with Python2.2 on RH7.1

Nadav Horesh nadavh at envision.co.il
Sat Jan 5 16:55:32 CST 2002


Hi!
I previously installed scipy with python2.1 and it was smooth. Recently
I am trying to move on to
python2.2 on the same machines (PIII (one with one CPU, the other with
2) running RH Linux 7.1),
and encounter the same problems:

  1. Can not find the FFTW single precision libraries (although I
     compiled FFTW with --enable float)
  2. When I removed the single precision libraries from setup.py, the
     installation went OK, but I am getting the following message when
     trying to import scipy:

>>> import scipy
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/local/lib/python2.2/site-packages/scipy/__init__.py", line
41, in ?    from handy import *
  File "/usr/local/lib/python2.2/site-packages/scipy/handy.py", line 2,
in ?
    import scipy.fft
  File "/usr/local/lib/python2.2/site-packages/scipy/fft/__init__.py",
line 3, in ?
    from FFT2 import *
  File "/usr/local/lib/python2.2/site-packages/scipy/fft/FFT2.py", line
3, in ?
    import Numeric, fftw, types
ImportError: /usr/local/lib/python2.2/site-packages/scipy/fft/fftw.so:
undefined symbol: fftw_threads_init

By the way: In the first trial it could not find fftw-threades (although
scipy is installed on those machines with python2.1 with the same fftw
libraries), so I recompiled FFTW to add those libraries.

  Nadav.




More information about the SciPy-user mailing list