[SciPy-user] Need help installing with Python 2.2 / 2.1 on Windows

eric eric at scipy.org
Wed Jan 23 15:45:35 CST 2002


Hey Michael,

I haven't worked with Python2.2 at all yet, but I'm guessing that the .exe
installer will only install with python2.1 because that is the system it was
built with.  There are quite a few extension modules (modules that are built
from C code instead of
written in Python) in SciPy, and these only work with one version of Python.
Hence,  the limitation to 2.1.  The exe was built with distutils, so I guess
the screen to choose a version in its install procedure, but it is also
smart enough to only allow
installation inot compatible versions of Python.  So, for now, your stuck
with 2.1.

More and more people are asking for a 2.2 version, and it is definitely in
the plans. Its safe to say that SciPy-0.2 will have both 2.1 and 2.2 exe
available.  When 0.2 will be released is still an open question.  The main
things left for 0.2 are getting the
linalg and stats modules cleaned up and better tested.  With the work of
Travis O. and Pearu, linalg is well on its way.  stats still is a bit
neglected, but Louis L. is getting some unittests whipped up for it which
will help.

eric

----- Original Message -----
From: "Michael George Lerner" <mlerner at umich.edu>
To: <scipy-user at scipy.net>
Sent: Wednesday, January 23, 2002 4:59 PM
Subject: [SciPy-user] Need help installing with Python 2.2 / 2.1 on Windows


>
> Hi,
>
> I have both Python 2.2 and Python 2.1 installed on my Windows box (in
> c:\python22 and c:\21).  When I try to install SciPy with the binary
> installer SciPy-0.1.win32-py2.1.exe, which I downloaded from the website
> on Jan. 23, the second screen says "Select python installation to choose"
> and only allows me to choose Python 2.1.  It doesn't notice my Python 2.2
> installation, so it's not in the list at the top of the screen.  Also, I
> can't edit the text in the text entry box at the bottom of the screen to
> manually point it at c:\python22.
>
> Is there some way to point SciPy at Python 2.2, or will I have to install
> with version 2.1?
>
> thanks,
>
> -michael
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user
>





More information about the SciPy-user mailing list