[SciPy-user] Re: Scipy help?

Pearu Peterson pearu at scipy.org
Mon Apr 26 12:53:59 CDT 2004



On Mon, 26 Apr 2004, Christopher Fonnesbeck wrote:

> Sorry, I didnt mean to send that to the list, but it sounds like its a  
> good thing that I did. On OSX, building scipy without disabling the  
> sparse module gives the following error:
> 
> gcc -Wl,-F. -Wl,-F. -bundle -framework Python  
> build/temp.darwin-7.3.0-Power_Macintosh-2.3/Lib/sparse/ 
> _zsuperlumodule.o  
> build/temp.darwin-7.3.0-Power_Macintosh-2.3/Lib/sparse/_superlu_utils.o  
> build/temp.darwin-7.3.0-Power_Macintosh-2.3/Lib/sparse/_superluobject.o  
> -Lbuild/temp.darwin-7.3.0-Power_Macintosh-2.3 -lsuperlu_src -o  
> build/lib.darwin-7.3.0-Power_Macintosh-2.3/scipy/sparse/_zsuperlu.so  
> -Wl,-framework -Wl,Accelerate
> ld: multiple definitions of symbol _scipy_superlu

Could you try adding

#define NO_IMPORT_ARRAY

line to _superluobject.c, just before the following line:

#include "_superluobject.h"

? Will linking work then?

Thanks,
Pearu



More information about the SciPy-user mailing list