[SciPy-user] gplt and xplt

David Grant david.grant at telus.net
Sat Aug 14 14:08:13 CDT 2004


Gary Ruben wrote:

>Alan,
>just a comment on your other point -
>
>  
>
>>Just to note on the particular issue raised by Gary:
>>gnuplot.py faces exactly the same problem as gplt but relies
>>on the user to implement apprpriate delays.  What is unclear
>>from the descriptions that I've read is whether this is a
>>gnuplot problem or a problem with pipes under Windows.
>>If the former, do the gnuplot developers know about it?
>>    
>>
>
>I always assumed this was a Windows pipe-system problem. I have experienced problems in other arenas with pipes under Win98 but not under Win2k in which the Windows pipe system changed. My experience of flakiness with pipes driving gnuplot also followed this pattern. ie. very occasionally, I get misbehaviour (broken plots) under Win98 but I haven't seen it under Win2k. When I experience a broken plot, I just re-run the script and it's typically fine. I don't use it interactively from Python.
>
>
>  
>
Doubtful.  It it was just a Windows pipe problem then the developer 
would have probably implemented a sleep just for win32 and not for 
linux-based systems.  Unless of course he/she didn't test it throughouly 
on linux.

-- 
David J. Grant
http://www.davidgrant.ca:81

-------------- next part --------------
A non-text attachment was scrubbed...
Name: david.grant.vcf
Type: text/x-vcard
Size: 177 bytes
Desc: not available
Url : http://www.scipy.net/pipermail/scipy-user/attachments/20040814/69e099b9/david.grant-0001.vcf


More information about the SciPy-user mailing list