[SciPy-user] fftpack fails on cvs build (OSX)

Christopher Fonnesbeck chris at fonnesbeck.org
Tue Feb 17 12:17:42 CST 2004


On Feb 17, 2004, at 11:51 AM, Bob Ippolito wrote:
>>>
>>
>> Doesnt work ... it can't seem to find python. I believe the  
>> appropriate way to link frameworks with g77 with "-Wl,-framework  
>> -Wl,Python". Using
>>
>> opt.append("-Wl,-framework -Wl,Python -lcc_dynamic")
>>
>> I am able to eliminate most of the errors, except for the following:
>>
>> /usr/local/bin/g77 -Wl,-framework -Wl,Python -lcc_dynamic  
>> build/temp.darwin-7.2.0-Power_Macintosh-2.3/build/src/Lib/fftpack/ 
>> _fftpackmodule.o  
>> build/temp.darwin-7.2.0-Power_Macintosh-2.3/Lib/fftpack/src/zfft.o  
>> build/temp.darwin-7.2.0-Power_Macintosh-2.3/Lib/fftpack/src/drfft.o  
>> build/temp.darwin-7.2.0-Power_Macintosh-2.3/Lib/fftpack/src/zrfft.o  
>> build/temp.darwin-7.2.0-Power_Macintosh-2.3/Lib/fftpack/src/zfftnd.o  
>> build/temp.darwin-7.2.0-Power_Macintosh-2.3/build/src/fortranobject.o  
>> -L/usr/local/lib -L/usr/local/lib/gcc/powerpc-apple-darwin7.0.0/3.4  
>> -Lbuild/temp.darwin-7.2.0-Power_Macintosh-2.3 -ldfftpack -lrfftw  
>> -lfftw -lg2c -o  
>> build/lib.darwin-7.2.0-Power_Macintosh-2.3/scipy/fftpack/_fftpack.so
>> /usr/bin/ld: Undefined symbols:
>> _MAIN__
>
> It probably needs a -bundle, right now it's probably trying to link as  
> an executable..
>
> -bob

Right, that would do it. This appears to work:

if sys.platform=='darwin':
          
	opt.extend(["-Wl,-framework","-Wl,Python","-lcc_dynamic","-bundle"])

--
Christopher J. Fonnesbeck ( c h r i s @ f o n n e s b e c k . o r g )
Georgia Cooperative Fish & Wildlife Research Unit, University of Georgia



More information about the SciPy-user mailing list