[SciPy-user] install SciPy with cygwin and Python 2.3x

Pearu Peterson pearu at scipy.org
Fri Feb 20 10:40:49 CST 2004



On Fri, 20 Feb 2004, el corto wrote:

> I've downloaded and installed the latest version of cygwin which comes with
> Python 2.3.3. The install instructions at 
> 
>    www.scipy.org/site_content/tutorials/install_binaries 
> 
<snip>

> I get error-messages like
> 
>     File "/usr/lib/python2.3/site-packages/scipy/__init__.py", line 36, in ?
>           from scipy_base import *
>     File "/usr/lib/python2.3/site-packages/scipy_base/__init__.py", line
> 110, in ?
>           raise ImportError, mess
>     ImportError: dlopen: Win32 error 126
> 
> OK, now what does that mean ?? I really hope that someone can give me a
> little hint :-) 

I cannot say what causes the above error but I suggest building scipy
under cygwin yourself, it is not so hard. See

  http://cens.ioc.ee/~pearu/scipy/BUILD_WIN32.html

HTH,
Pearu



More information about the SciPy-user mailing list