[SciPy-user] IRIX problems

Pearu Peterson pearu at scipy.org
Mon Jun 28 10:39:56 CDT 2004



On Mon, 28 Jun 2004, Martin Wiechert wrote:

> Hi all,
> 
> I'm trying to install scipy on our dunno-how-old IRIX server.
> I've used a lib called complib.sgimath instead of atlas/LAPACK ...
> Now I get the following error:
> 
>     import lapack_lite
> ImportError: 563534:python2.3: rld: Fatal Error: unresolvable symbol 
> in /user/wiechert/lib/python2.3/site-packages/Numeric/lapack_lite.so: zgelsd_

(This is a Numeric installation problem, not scipy.)

> lapack_lite is linked against following libs:
> ldd lapack_lite.so
>         libcomplib.sgimath.so  =>        /usr/lib32/libcomplib.sgimath.so
>         libblas.so  =>   /usr/lib32/libblas.so
>         libftn.so  =>    /usr/lib32/libftn.so
>         libm.so  =>      /usr/lib32/libm.so
>         libc.so.1  =>    /usr/lib32/libc.so.1
> 
> What can I do?

Try to find out which libraries in your system contain zgelsd_ and use it 
when linking lapack_lite. When that's unsuccessful then I suggest building 
LAPACK libraries yourself, see the relevant section in

  http://www.scipy.org/documentation/buildatlas4scipy.txt

HTH,
Pearu



More information about the SciPy-user mailing list