[SciPy-user] Scipy build under win32

Pearu Peterson pearu at scipy.org
Tue Mar 9 00:47:24 CST 2004



On Mon, 8 Mar 2004, Massimo Sabbatini wrote:

> Dear all,
> 
> I tried to build scipy (cvs checkout) under win32. I installed MinGW and 
>   followed quite closely Pearu's instructions at
> http://cens.ioc.ee/~pearu/scipy/BUILD_WIN32.html
> However, at the final scipy build stage, when I type
> 
> $ msys.py python setup.py build
> 
> I obtain the following:
> 
> Traceback (most recent call last):
>    File "setup.py", line 125, in ?
>      setup_package(ignore_packages)
>    File "setup.py", line 98, in setup_package
>      parent_path=local_path)
>    File "setup.py", line 59, in get_packages
>      config = setup_module.configuration(*args)
>    File "c:\build\scipy\Lib\integrate\setup_integrate.py", line 21, in 
> configuration
>      raise NotFoundError,'no blas resources found'
> scipy_distutils.system_info.NotFoundError: no blas resources found
> 
> However, my blas library is correctly found when I run system_info.py
> 
> Any hints, suggestions ?

How did you specify the locations of blas/lapack libraries? There are 
several ways to do it, for instance, I use

  export BLAS=~/src/blas/libfblas.a
  export LAPACK=~/src/LAPACK/liblapack.a

before running

  msys.py python setup.py build  

and I just checked, it works with the recent CVS.

Or may be you are using ATLAS? Then I would set

  export ATLAS=~/src/ATLAS/lib/WinNT_P4SSE2

before the build command, and again, it works here.
(Of course, the targets of the above environment variables should 
contain something sensible;)

When you run system_info.py, it shows the paths where the blas libraries
are looked for, something like

blas_info:
Replacing _lib_names[0]=='blas' with 'fblas'
( library_dirs = c:/cygwin/home/pearu/src/blas:c:\Py233\lib:C:\ )
( paths: c:/cygwin/home/pearu/src/blas\libfblas.a )
  FOUND:
    libraries = ['fblas']
    library_dirs = ['c:/cygwin/home/pearu/src/blas']
    language = f77

To enable these messages also for `setup.py build`, change the line #236

     verbosity = 1

in system_info.py to

     verbosity = 2

How the corresponding `blas_info:..` messages compare when running 
system_info.py or `setup.py build`?

Pearu



More information about the SciPy-user mailing list