[SciPy-user] Error building statlib.so

Christopher Fonnesbeck chris at fonnesbeck.org
Sat Mar 13 08:36:10 CST 2004


On Mar 13, 2004, at 3:49 AM, Pearu Peterson wrote:

> Acctually, the latest CVS version of gnufcompiler.py contains
>
>           if sys.platform=='darwin':
>              if sys.executable.startswith('/usr/bin'):
>                  # This is when Python is from Apple framework
>                  opt.extend(["-Wl,-framework","-Wl,Python"])
>              #else we are running in Fink python.
>              opt.extend(["-lcc_dynamic","-bundle"])
>           else:
>              ...
>
> which means that in your case Python is assumed to be Fink Python but
> obviously (?) you are using Apple Python that is just installed to
> nonstandard (?) location.
> Could you guys and girls running on OSX find out what is the most 
> robust
> way to determine that Python is either of Apple or Fink one? May be
> sys.version should be used instead of sys.executable for that?


Python is in /usr/bin, so I'm not sure why it isnt working. There is 
nothing non-standard about my installation, AFAIK. Do people really use 
fink python?

C.

--
Christopher J. Fonnesbeck ( c h r i s @ f o n n e s b e c k . o r g )
Georgia Cooperative Fish & Wildlife Research Unit, University of Georgia



More information about the SciPy-user mailing list