[SciPy-user] Problem when building scipy 0.3 for alpha OSF1

Pearu Peterson pearu at scipy.org
Fri May 21 09:59:10 CDT 2004



On Fri, 21 May 2004, Jean-Luc Menut wrote:

> I' ve installed newer version of python and numeric (2.3.3 and 23.1).
> When i try to build scipy (the last cvs version) i have another error 
> message :
> 
> 
> error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall 
> -Wstrict-prototypes -Ibuild/temp.osf1-V5.1-alpha-2.3/config_pygist 
> -ILib/xplt/src/gist -ILib/xplt/src/play -ILib/xplt/src/play/unix 
> -I/usr/include -I/usr/include 
> -I/home2/menut/prg/python2.3/include/python2.3 -c 
> Lib/xplt/pygist/gistCmodule.c -o 
> build/temp.osf1-V5.1-alpha-2.3/Lib/xplt/pygist/gistCmodule.o 
> -DGISTPATH="\"/home2/menut/prg/python2.3/lib/python2.3/site-packages/scipy/xplt/gistdata\"" 
> -DNO_EXP10" failed with exit status 1
> 1.77u 2.16s 1:00 6% 20+27k 210+332io 0pf+0w

It is not a real error message. It just says that the above command line 
failed. The real error message should have been shown earlier.

Anyways, it's looks like xplt is the only scipy module that fails to 
build. You can disable it by adding 'xplt' to ignore_packags list at the 
end of setup.py file, at least you could then install and test scipy.

Pearu



More information about the SciPy-user mailing list