[SciPy-user] problems with scipy.test() on Opteron 64-bit

Giovanni Samaey Giovanni.Samaey at cs.kuleuven.ac.be
Thu Nov 25 04:16:53 CST 2004


I tried all your suggestions:
- I compiled scipy against my BLAS and LAPACK libraries
- I compiled scipy giving only BLAS and LAPACK source (which was then 
compiled during scipy build)
- I upgraded f2py and built scipy against altas3.7.8; blas/lapack 
libraries and blas/lapack source.
There is no difference.

>
> It is interesting that only simple eig tests fail while complex and 
> random
> tests pass. And in these simple tests eigenvalues are only slightly 
> incorrect.

What is remarkable is that, the error is the same in the 3 cases.  
Moreover, if you add up
the first two components of array1 you get the first component of array2.

======================================================================
FAIL: check_simple (scipy.linalg.decomp.test_decomp.test_eigvals)
----------------------------------------------------------------------
Traceback (most recent call last):
  File 
"/data/home/giovanni/lib/python2.3/site-packages/scipy/linalg/tests/test_decomp.py", 
line 36, in check_simple
    assert_array_almost_equal(w,exact_w)
  File 
"/data/home/giovanni/lib/python2.3/site-packages/scipy_test/testing.py", 
line 727,
in assert_array_almost_equal
    assert cond,\
AssertionError:
Arrays are not almost equal (mismatch 66.6666666667%):
        Array 1: [ 9.4371906+0.j -0.1153653+0.j -0.3218254+0.j]
        Array 2: [ 9.3218254  0.        -0.3218254]


Giovanni



More information about the SciPy-user mailing list