[SciPy-user] Problems testing SciPy 0.3.2

Francesc Alted falted at pytables.org
Fri Oct 15 05:28:36 CDT 2004


Hi,

I've just installed the newest SciPy 0.3.2, and all tests seems to pass
well, except 15 (out of 574). All of them are caused by the same reason,
which ultimately is:

File "/users/exp/alted/bin-i686/lib/python/scipy/special/orthogonal.py", line 91, in get_eig_func
    eig = scipy.linalg.eig
AttributeError: 'module' object has no attribute 'eig'

I'm attaching the information required in the INSTALL.txt for reporting bugs.

Cheers,

-- 
Francesc Alted

-------------- next part --------------
$ python -c 'from f2py2e.diagnose import run;run()'
------
os.name='posix'
------
sys.platform='linux2'
------
sys.version:
2.3.4 (#1, Jul 22 2004, 20:47:54)
[GCC 3.3.2 20031022 (Red Hat Linux 3.3.2-1)]
------
sys.prefix:
/usr
------
sys.path=':/users/exp/alted/bin-i686/lib/python:/usr/lib/python23.zip:/usr/lib/python2.3:/usr/lib/python2.3/plat-linux2:/usr/lib/python2.3/lib-tk:/usr/lib/python2.3/lib-dynload:/usr/lib/python2.3/site-packages:/usr/lib/python2.3/site-packages/Numeric'
------
Found Numeric version '23.3' in /usr/lib/python2.3/site-packages/Numeric/Numeric.pyc
Found numarray version '1.1' in /usr/lib/python2.3/site-packages/numarray/__init__.pyc
Found f2py2e version '2.43.239_1844' in /users/exp/alted/bin-i686/lib/python/f2py2e/f2py2e.pyc
Found scipy_distutils version '0.3.2_33.550' in '/users/exp/alted/bin-i686/lib/python/scipy_distutils/__init__.pyc'
------
Importing scipy_distutils.command.build_flib ... error: No module named build_flib
------
Checking availability of supported Fortran compilers:
error: local variable 'build_flib' referenced before assignment
------
Importing scipy_distutils.fcompiler ... ok
------
Checking availability of supported Fortran compilers:
List of available Fortran compilers:
  --fcompiler=gnu  GNU Fortran Compiler (3.2.3)
For compiler details, run 'config_fc --verbose' setup command.
------
Importing scipy_distutils.command.cpuinfo ... error: No module named cpuinfo
Importing scipy_distutils.cpuinfo ... ok
------
CPU information: getNCPUs has_mmx has_sse has_sse2 is_32bit is_Intel ------
------
Atlas version:

[alted at api linalg]$      python -c 'import atlas_version'
Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: ./atlas_version.so: undefined symbol: ATL_buildinfo

This does not seem to work, but my ATLAS version is 3.6.0. I've also read
http://math-atlas.sourceforge.net/errata.html#completelp in order to get 
complete LAPACK support.
------
[alted at api SciPy_complete-0.3.2]$ python scipy_core/scipy_distutils/system_info.py
_pkg_config_info:
  NOT AVAILABLE

agg2_info:
( src_dirs = .:/usr/local/src )
  NOT AVAILABLE

atlas_blas_info:
( library_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/lib:/usr/lib )
( paths: /users/exp/alted/bin-i686/lib/atlas/libf77blas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libcblas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libatlas.a )
system_info.atlas_blas_info
( include_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/include:/usr/include )
( paths: /users/exp/alted/bin-i686/lib/atlas/cblas.h,/users/exp/alted/bin-i686/lib/atlas/cblas.h )
  FOUND:
    libraries = ['f77blas', 'cblas', 'atlas']
    library_dirs = ['/users/exp/alted/bin-i686/lib/atlas']
    language = c
    include_dirs = ['/users/exp/alted/bin-i686/lib/atlas']

atlas_blas_threads_info:
( library_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/lib:/usr/lib )
( paths: /users/exp/alted/bin-i686/lib/atlas/libptf77blas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libptcblas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libatlas.a )
system_info.atlas_blas_threads_info
( include_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/include:/usr/include )
( paths: /users/exp/alted/bin-i686/lib/atlas/cblas.h,/users/exp/alted/bin-i686/lib/atlas/cblas.h )
  FOUND:
    libraries = ['ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/users/exp/alted/bin-i686/lib/atlas']
    language = c
    include_dirs = ['/users/exp/alted/bin-i686/lib/atlas']

atlas_info:
( library_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/lib:/usr/lib )
( paths: /users/exp/alted/bin-i686/lib/atlas/libf77blas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libcblas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libatlas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/liblapack.a )
system_info.atlas_info
( include_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/include:/usr/include )
( paths: /users/exp/alted/bin-i686/lib/atlas/cblas.h,/users/exp/alted/bin-i686/lib/atlas/cblas.h )
  FOUND:
    libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
    library_dirs = ['/users/exp/alted/bin-i686/lib/atlas']
    language = f77
    include_dirs = ['/users/exp/alted/bin-i686/lib/atlas']

atlas_threads_info:
( library_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/lib:/usr/lib )
( paths: /users/exp/alted/bin-i686/lib/atlas/libptf77blas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libptcblas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libatlas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/liblapack.a )
system_info.atlas_threads_info
( include_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/include:/usr/include )
( paths: /users/exp/alted/bin-i686/lib/atlas/cblas.h,/users/exp/alted/bin-i686/lib/atlas/cblas.h )
  FOUND:
    libraries = ['lapack', 'ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/users/exp/alted/bin-i686/lib/atlas']
    language = f77
    include_dirs = ['/users/exp/alted/bin-i686/lib/atlas']

blas_info:
( library_dirs = /usr/local/lib:/usr/lib )
( paths: /usr/lib/libblas.so )
  FOUND:
    libraries = ['blas']
    library_dirs = ['/usr/lib']
    language = f77

blas_opt_info:
running build_src
building extension "atlas_version" sources
  adding 'build/src/atlas_version_0x32c8fc2f.c' to sources.
running build_ext
customize UnixCCompiler
customize UnixCCompiler using build_ext
  FOUND:
    libraries = ['ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/users/exp/alted/bin-i686/lib/atlas']
    language = c
    define_macros = [('ATLAS_INFO', '"\\"3.2.1_pre3.3.6\\""')]
    include_dirs = ['/users/exp/alted/bin-i686/lib/atlas']

blas_src_info:
( src_dirs = .:/usr/local/src )
  NOT AVAILABLE

boost_python_info:
( src_dirs = .:/usr/local/src )
  NOT AVAILABLE

dfftw_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

dfftw_threads_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

djbfft_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

fftw_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

fftw_threads_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

freetype2_info:
  NOT AVAILABLE

gdk_2_info:
  FOUND:
    libraries = ['gdk-x11-2.0', 'gdk_pixbuf-2.0', 'm', 'pangoxft-1.0', 'pangox-1.0', 'pango-1.0', 'gobject-2.0', 'gmodule-2.0', 'dl', 'glib-2.0']
    extra_link_args = ['-Wl,--export-dynamic']
    define_macros = [('GDK_2_INFO', '"\\"2.2.4\\""'), ('GDK_VERSION_2_2_4', None)]
    include_dirs = ['/usr/include/gtk-2.0', '/usr/lib/gtk-2.0/include', '/usr/include/pango-1.0', '/usr/X11R6/include', '/usr/include/freetype2', '/usr/include/glib-2.0', '/usr/lib/glib-2.0/include']

gdk_info:
  FOUND:
    libraries = ['gdk', 'Xi', 'Xext', 'X11', 'm', 'glib']
    library_dirs = ['/usr/X11R6/lib']
    define_macros = [('GDK_INFO', '"\\"1.2.10\\""'), ('GDK_VERSION_1_2_10', None)]
    include_dirs = ['/usr/include/gtk-1.2', '/usr/X11R6/include', '/usr/include/glib-1.2', '/usr/lib/glib/include']

gdk_pixbuf_2_info:
  FOUND:
    libraries = ['gdk_pixbuf-2.0', 'm', 'gobject-2.0', 'gmodule-2.0', 'dl', 'glib-2.0']
    extra_link_args = ['-Wl,--export-dynamic']
    define_macros = [('GDK_PIXBUF_2_INFO', '"\\"2.2.4\\""'), ('GDK_PIXBUF_VERSION_2_2_4', None)]
    include_dirs = ['/usr/include/gtk-2.0', '/usr/include/glib-2.0', '/usr/lib/glib-2.0/include']

gdk_pixbuf_xlib_2_info:
  FOUND:
    libraries = ['gdk_pixbuf_xlib-2.0', 'gdk_pixbuf-2.0', 'm', 'gobject-2.0', 'gmodule-2.0', 'dl', 'glib-2.0']
    extra_link_args = ['-Wl,--export-dynamic']
    define_macros = [('GDK_PIXBUF_XLIB_2_INFO', '"\\"2.2.4\\""'), ('GDK_PIXBUF_XLIB_VERSION_2_2_4', None)]
    include_dirs = ['/usr/include/gtk-2.0', '/usr/include/glib-2.0', '/usr/lib/glib-2.0/include']

gdk_x11_2_info:
  FOUND:
    libraries = ['gdk-x11-2.0', 'gdk_pixbuf-2.0', 'm', 'pangoxft-1.0', 'pangox-1.0', 'pango-1.0', 'gobject-2.0', 'gmodule-2.0', 'dl', 'glib-2.0']
    extra_link_args = ['-Wl,--export-dynamic']
    define_macros = [('GDK_X11_2_INFO', '"\\"2.2.4\\""'), ('GDK_X11_VERSION_2_2_4', None)]
    include_dirs = ['/usr/include/gtk-2.0', '/usr/lib/gtk-2.0/include', '/usr/include/pango-1.0', '/usr/X11R6/include', '/usr/include/freetype2', '/usr/include/glib-2.0', '/usr/lib/glib-2.0/include']

gtkp_2_info:
  FOUND:
    libraries = ['gtk-x11-2.0', 'gdk-x11-2.0', 'atk-1.0', 'gdk_pixbuf-2.0', 'm', 'pangoxft-1.0', 'pangox-1.0', 'pango-1.0', 'gobject-2.0', 'gmodule-2.0', 'dl', 'glib-2.0']
    extra_link_args = ['-Wl,--export-dynamic']
    define_macros = [('GTKP_2_INFO', '"\\"2.2.4\\""'), ('GTK_VERSION_2_2_4', None)]
    include_dirs = ['/usr/include/gtk-2.0', '/usr/lib/gtk-2.0/include', '/usr/include/atk-1.0', '/usr/include/pango-1.0', '/usr/X11R6/include', '/usr/include/freetype2', '/usr/include/glib-2.0', '/usr/lib/glib-2.0/include']

gtkp_x11_2_info:
  FOUND:
    libraries = ['gtk-x11-2.0', 'gdk-x11-2.0', 'atk-1.0', 'gdk_pixbuf-2.0', 'm', 'pangoxft-1.0', 'pangox-1.0', 'pango-1.0', 'gobject-2.0', 'gmodule-2.0', 'dl', 'glib-2.0']
    extra_link_args = ['-Wl,--export-dynamic']
    define_macros = [('GTKP_X11_2_INFO', '"\\"2.2.4\\""'), ('GTK_X11_VERSION_2_2_4', None)]
    include_dirs = ['/usr/include/gtk-2.0', '/usr/lib/gtk-2.0/include', '/usr/include/atk-1.0', '/usr/include/pango-1.0', '/usr/X11R6/include', '/usr/include/freetype2', '/usr/include/glib-2.0', '/usr/lib/glib-2.0/include']

lapack_atlas_info:
( library_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/lib:/usr/lib )
( paths: /users/exp/alted/bin-i686/lib/atlas/libf77blas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libcblas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libatlas.a )
system_info.lapack_atlas_info
  NOT AVAILABLE

lapack_atlas_threads_info:
( library_dirs = /users/exp/alted/bin-i686/lib/atlas:/usr/local/lib:/usr/lib )
( paths: /users/exp/alted/bin-i686/lib/atlas/libptf77blas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libptcblas.a )
( paths: /users/exp/alted/bin-i686/lib/atlas/libatlas.a )
system_info.lapack_atlas_threads_info
  NOT AVAILABLE

lapack_info:
( library_dirs = /usr/local/lib:/usr/lib )
( paths: /usr/lib/liblapack.so )
  FOUND:
    libraries = ['lapack']
    library_dirs = ['/usr/lib']
    language = f77

lapack_opt_info:
/scratch1/alted/SciPy_complete-0.3.2/scipy_core/scipy_distutils/system_info.py:812: FutureWarning: hex()/oct() of negative int will return a signed string in Python 2.4 and up
  magic = hex(hash(`config`))
running build_src
building extension "atlas_version" sources
  adding 'build/src/atlas_version_0xe6b7fbc8.c' to sources.
running build_ext
customize UnixCCompiler
customize UnixCCompiler using build_ext
customize GnuFCompiler
customize GnuFCompiler
customize GnuFCompiler using build_ext
  FOUND:
    libraries = ['lapack', 'ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/users/exp/alted/bin-i686/lib/atlas']
    language = f77
    define_macros = [('ATLAS_INFO', '"\\"3.2.1_pre3.3.6\\""')]
    include_dirs = ['/users/exp/alted/bin-i686/lib/atlas']

lapack_src_info:
( src_dirs = .:/usr/local/src )
  NOT AVAILABLE

numarray_info:
( include_dirs = /usr/include/python2.3 )
( paths: /usr/include/python2.3/numarray/arrayobject.h )
  FOUND:
    define_macros = [('NUMARRAY_VERSION', '"\\"1.1\\""')]
    include_dirs = ['/usr/include/python2.3']

numpy_info:
( include_dirs = /usr/include/python2.3 )
( paths: /usr/include/python2.3/Numeric/arrayobject.h )
  FOUND:
    define_macros = [('NUMERIC_VERSION', '"\\"23.3\\""')]
    include_dirs = ['/usr/include/python2.3']

sfftw_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

sfftw_threads_info:
( library_dirs = /usr/local/lib:/usr/lib )
( include_dirs = /usr/local/include:/usr/include )
  NOT AVAILABLE

wx_info:
  FOUND:
    libraries = ['wx_gtk-2.5']
    extra_link_args = ['-pthread']
    library_dirs = ['/users/exp/alted/bin-i686//lib', '/usr/X11R6/lib']
    define_macros = [('WX_INFO', '"\\"2.5.2\\""'), ('WX_VERSION_2_5_2', None), ('WX_RELEASE_2_5', None), ('GTK_NO_CHECK_CASTS', None), ('__WXGTK__', None), ('_FILE_OFFSET_BITS', '64'), ('_LARGE_FILES', None)]
    include_dirs = ['/users/exp/alted/bin-i686//lib/wx/include/gtk-2.5', '/users/exp/alted/bin-i686//include/wx-2.5']

x11_info:
( library_dirs = /usr/X11R6/lib:/usr/lib )
( include_dirs = /usr/X11R6/include:/usr/include )
( paths: /usr/X11R6/lib/libX11.so )
( paths: /usr/X11R6/include/X11/X.h )
  FOUND:
    libraries = ['X11']
    library_dirs = ['/usr/X11R6/lib']
    include_dirs = ['/usr/X11R6/include']

xft_info:
  FOUND:
    libraries = ['Xft', 'X11', 'freetype', 'Xrender', 'fontconfig']
    library_dirs = ['/usr/X11R6/lib']
    define_macros = [('XFT_INFO', '"\\"2.1.2\\""'), ('XFT_VERSION_2_1_2', None)]
    include_dirs = ['/usr/X11R6/include', '/usr/include/freetype2']

[alted at api SciPy_complete-0.3.2]$ python scipy_core/scipy_distutils/command/build
python: can't open file 'scipy_core/scipy_distutils/command/build'
???

Other useful information:
Running RedHat Linux with 
Linux api.uji.es 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:46:40 EDT 2004 i686 i686 i386 GNU/Linux



More information about the SciPy-user mailing list