[SciPy-user] Problems testing SciPy 0.3.2

Francesc Alted falted at pytables.org
Fri Oct 15 07:06:36 CDT 2004


Hi Peauru,

A Divendres 15 Octubre 2004 13:44, Pearu Peterson va escriure:
> Where your ATLAS-3.6.0 libraries are located? Did you use ATLAS 
> environment variable to specify the location?

They are at:

$ ll /users/exp/alted/bin-i686/lib/atlas/
total 12460
-rw-r--r--    1 alted    exp         33895 oct 15 11:26 cblas.h
-rw-r--r--    1 alted    exp          8225 oct 15 11:26 clapack.h
-rw-r--r--    1 alted    exp       6569928 oct 15 11:24 libatlas.a
-rw-r--r--    1 alted    exp        205476 oct 15 11:24 libcblas.a
-rw-r--r--    1 alted    exp        233716 oct 15 11:24 libf77blas.a
-rw-r--r--    1 alted    exp       4963424 oct 15 11:24 liblapack.a
-rw-r--r--    1 alted    exp        205954 oct 15 11:24 libptcblas.a
-rw-r--r--    1 alted    exp        234084 oct 15 11:24 libptf77blas.a
-rw-r--r--    1 alted    exp        234972 oct 15 11:24 libtstatlas.a

and yes, I've used $ATLAS

$ echo $ATLAS
/users/exp/alted/bin-i686/lib/atlas

> scipy_distutils seems to  find only ATLAS-3.2.1 or ATLAS-pre3.3.6 
> libraries in  /users/exp/alted/bin-i686/lib/atlas/.

I don't know why this is happening. I'm sure that I've installed the 3.6.0
version (it is the latest stable, isn't it?). I did make a strip (i.e. strip
out all the debugging info) on the ATLAS libraries. Would that cause some
problem?

Thanks,

-- 
Francesc Alted



More information about the SciPy-user mailing list