[SciPy-user] Problems testing SciPy 0.3.2

Francesc Alted falted at pytables.org
Fri Oct 15 10:59:36 CDT 2004


A Divendres 15 Octubre 2004 16:50, Pearu Peterson va escriure:
> > I don't know why this is happening. I'm sure that I've installed the 3.6.0
> > version (it is the latest stable, isn't it?). I did make a strip (i.e. strip
> > out all the debugging info) on the ATLAS libraries. Would that cause some
> > problem?
> 
> I am not sure.

I can confirm that *this* was the problem on getting the correct ATLAS
version.

> Could you try the following program
> 
>    http://math-atlas.sourceforge.net/faq.html#probeV

Without stripping libraries:

$ gcc  xprint_buildinfo.c -o xprint_buildinfo -L $ATLAS -latlas
[alted at api alted]$ ./xprint_buildinfo
ATLAS version 3.6.0 built by alted on vie oct 15 17:02:42 CEST 2004:
   UNAME    : Linux api.uji.es 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:46:40 EDT 2004 i686 i686 i386 GNU/Linux
   INSTFLG  :
   MMDEF    : /scratch1/alted/ATLAS/CONFIG/ARCHS/P4SSE2/gcc/gemm
   ARCHDEF  : /scratch1/alted/ATLAS/CONFIG/ARCHS/P4SSE2/gcc/misc
   F2CDEFS  : -DAdd__ -DStringSunStyle
   CACHEEDGE: 1048576
   F77      : /usr/bin/g77, version GNU Fortran (GCC 3.2.3 20030502 (Red Hat Linux 3.2.3-42)) 3.2.3 20030502 (Red Hat Linux 3.2.3-42)
   F77FLAGS : -fomit-frame-pointer -O
   CC       : /usr/bin/gcc, version gcc (GCC) 3.2.3 20030502 (Red Hat Linux 3.2.3-42)
   CC FLAGS : -fomit-frame-pointer -O3 -funroll-all-loops
   MCC      : /usr/bin/gcc, version gcc (GCC) 3.2.3 20030502 (Red Hat Linux 3.2.3-42)
   MCCFLAGS : -fomit-frame-pointer -O

Stripping the libraries:

$ strip ATLAS/lib/Linux_P4SSE2_2/*.a
$ gcc  xprint_buildinfo.c -o xprint_buildinfo -L ATLAS/lib/Linux_P4SSE2_2 -latlas
/tmp/ccyNzrVf.o(.text+0x11): In function `main':
: undefined reference to `ATL_buildinfo'
collect2: ld returned 1 exit status

So, I removed scipy from python repository, deleted scipy source dir,
unpacked it again, recompiled it *against* the new, corrected ATLAS libs,
and... the same problem remains. However, now the number of tests are 600
instead of 574 with the stripped libs. The number of failed tests are 15 as
before.

I'm attaching the complete output of 

$ python scipy_core/scipy_distutils/system_info.py

command.

One of the error looks like:

======================================================================
ERROR: check_sh_legendre (scipy.special.basic.test_basic.test_sh_legendre)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/users/exp/alted/bin-i686//lib/python/scipy/special/tests/test_basic.py", line 1806, in check_sh_legendre
    Ps1 = sh_legendre(1)
  File "/users/exp/alted/bin-i686//lib/python/scipy/special/orthogonal.py", line 593, in sh_legendre
    x,w,mu0 = ps_roots(n,mu=1)
  File "/users/exp/alted/bin-i686//lib/python/scipy/special/orthogonal.py", line 584, in ps_roots
    return js_roots(n,1.0,1.0,mu=mu)
  File "/users/exp/alted/bin-i686//lib/python/scipy/special/orthogonal.py", line 205, in js_roots
    val = gen_roots_and_weights(n,an_Js,sbn_Js,mu0)
  File "/users/exp/alted/bin-i686//lib/python/scipy/special/orthogonal.py", line 121, in gen_roots_and_weights
    eig = get_eig_func()
  File "/users/exp/alted/bin-i686//lib/python/scipy/special/orthogonal.py", line 91, in get_eig_func
    eig = scipy.linalg.eig
AttributeError: 'module' object has no attribute 'eig'

Cheers,

-- 
Francesc Alted



More information about the SciPy-user mailing list