[SciPy-user] scipy debian packages

Travis Oliphant oliphant at ee.byu.edu
Thu Oct 21 12:01:39 CDT 2004


Arnd Baecker wrote:

>On Wed, 20 Oct 2004, Robert Kern wrote:
>
>  
>
>>Arnd Baecker wrote:
>>
>>    
>>
>>>  File "/usr/lib/python2.3/site-packages/scipy/xplt/slice3.py", line 1575,
>>>in _construct3
>>>    mask = find_mask (below, _node_edges3 [itype])
>>>TypeError: Array can not be safely cast to required type
>>>      
>>>
>>This is a problem with Numeric. Bug the maintainer of python-numeric to
>>update from the latest 23.5 tarball. The fix somehow didn't make it into
>>the first release of the 23.5 tarball but should be in the copy there now.
>>    
>>
>
>Many thanks! Do you have a simple example demonstrating the problem
>in pure Numeric code?
>(this would make it simpler to illustrate/test the problem without
>referring to scipy and thus more convincing, IMHO).
>
>Until that happens: is there a file which I could hand-edit
>in my installation (of course this would only work if it is on the .py
>level) to remove the problem for the moment?
>
>  
>
don't import slice3.py 

-Travis



More information about the SciPy-user mailing list