[SciPy-user] Installing problem: newbie with a new machine

David M.Cooke cookedm at physics.mcmaster.ca
Sun Sep 5 22:11:44 CDT 2004


On Sep 4, 2004, at 09:25, Angelo Secchi wrote:
> Hi,
> I have a working scipy installation on a 32bit Suse machine and I'm
> trying to install it on a dual opteron machine with gentoo. I obtain
> this error

"trying to install" -> I presume from scratch? Not copying the binaries 
(I'm just a little confused by your use of "have a working installation 
and trying to install it").

I presume you're trying to make a 64-bit version for the opteron?

> error: Command "/usr/x86_64-pc-linux-gnu/gcc-bin/3.3/g77 -shared
> build/temp.linux-x86_64-2.3/build/src/build/src/fblasmodule.o
> build/temp.linux-x86_64-2.3/build/src/fortranobject.o
> build/temp.linux-x86_64-2.3/Lib/linalg/src/fblaswrap.o
> -L/usr/local/Linux_HAMMER64SSE2_2/lib/ -Lbuild/temp.linux-x86_64-2.3
>        -llapack -lptf77blas -lptcblas-latlas -lg2c -o
>  build/lib.linux-x86_64-2.3/scipy/linalg/fblas.so" failed with exit
> status 1

There's not a lot here to go on. I'm not familiar with gentoo, but
check if there is a flag for emerge to show all the steps it takes
while compiling (-v or something). The message above just shows what
command failed, but not the more informative error message that g77 
probably printed out.

My guess (because this is a common problem :-) is that you're missing
part of LAPACK (you need the full version, as well as the optimized
bits that ATLAS provides).

|>|\/|<
/------------------------------------------------------------------\
|David M. Cooke              http://arbutus.physics.mcmaster.ca/dmc/
|cookedm at physics.mcmaster.ca



More information about the SciPy-user mailing list