[SciPy-user] installing numeric, newbie

Darren Dale dd55 at cornell.edu
Wed Sep 15 15:33:48 CDT 2004


Hi,

I am trying to compile numeric 23.3 on a gentoo-linux machine. I have
successfully installed atlas 3.4.2, made the required edits to point
setup.py to my libraries (/usr/lib/atlas, /usr/include), but am getting an
error when I try to build numeric. It looks like its not finding the
libraries I just mentioned, but I am sure they are appropriately
addressed. Could anyone offer a suggestion? I am running out of ideas.

Thank you,
Darren



running install
[clip]
building 'lapack_lite' extension
gcc -fno-strict-aliasing -DNDEBUG -fPIC -I/usr/include -IInclude
-IPackages/FFT/Include -IPackages/RNG/Include -I/usr/include/python2.3 -c
Src/lapack_litemodule.c -o
build/temp.linux-i686-2.3/Src/lapack_litemodule.o
gcc -pthread -shared build/temp.linux-i686-2.3/Src/lapack_litemodule.o
-L/usr/lib/atlas -llapack -lcblas -lf77blas -latlas -o
build/lib.linux-i686-2.3/lapack_lite.so
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/../../../../i686-pc-linux-gnu/bin/ld:
cannot find -llapack
collect2: ld returned 1 exit status
error: command 'gcc' failed with exit status 1




More information about the SciPy-user mailing list