[SciPy-user] problems with glplt and new scipy install

Robert Kern rkern at ucsd.edu
Sat Apr 23 21:26:47 CDT 2005


Alimamy Bangura wrote:
> Hi,
> 
> I have just spent a long time getting a version of
> scipy  installed on my powerbook G4 . I am a newbie to
> python and the whole unix thing so I have found the
> whole ordeal rather difficult, but interesting!
> 
> All seemed lost until I found the package by Peter
> Maxwell at:
> 
> http://cbis.anu.edu.au/misc/SciPy_complete-0.3.2.mpkg.zip
> 
> I should really have looked at this list first before
> trying to build from the source... 
> 
> It all seems to work great except plotting with glplt.
> The program I have been testing with I know works on
> other machines, but doesn't work when I use it on
> mine.
> 
> I can import scipy and the scipy.test() seems to work
> fine. I have reinstalled the newest version of xfree86
> from fink, after deleting all previous incarnations,
> but it just doesn't open the window when it is
> supposed to, no error message is popped up either.

Whose gnuplot are you using? IIRC, Fink's gnuplot doesn't use X. Use 
Fink to install AquaTerm.

I do recommend using matplotlib instead.

-- 
Robert Kern
rkern at ucsd.edu

"In the fields of hell where the grass grows high
  Are the graves of dreams allowed to die."
   -- Richard Harter



More information about the SciPy-user mailing list