[SciPy-user] installing problems

Adrian L. Garcia-Lomana alopez at cds.caltech.edu
Wed Aug 17 17:51:04 CDT 2005


Hi all,

I have a problem installing SciPy. I'm sure is not a problem of SciPy but
of my computer, but I am quite lost.

When I execute as root "pyhton setup.py install", after a while, this is
the error:

gcc: Lib/xplt/src/play/x11/errors.c
In file included from Lib/xplt/src/play/x11/errors.c:9:
Lib/xplt/src/play/x11/playx.h:11:22: X11/Xlib.h: No such file or directory
In file included from Lib/xplt/src/play/x11/errors.c:9:
Lib/xplt/src/play/x11/playx.h:29: parse error before "Display"
Lib/xplt/src/play/x11/playx.h:29: warning: no semicolon at end of struct
or union
Lib/xplt/src/play/x11/playx.h:31: warning: type defaults to `int' in
declaration of `wm_protocols'
Lib/xplt/src/play/x11/playx.h:31: warning: type defaults to `int' in
declaration of `wm_delete'
Lib/xplt/src/play/x11/playx.h:31: warning: data definition has no type or
storage class
Lib/xplt/src/play/x11/playx.h:34: parse error before '*' token
Lib/xplt/src/play/x11/playx.h:34: warning: type defaults to `int' in
declaration of `font'
Lib/xplt/src/play/x11/playx.h:34: warning: data definition has no type or
storage class
Lib/xplt/src/play/x11/playx.h:38: parse error before "XFontStruct"
Lib/xplt/src/play/x11/playx.h:38: warning: no semicolon at end of struct
or union
Lib/xplt/src/play/x11/playx.h:39: conflicting types for `font'
Lib/xplt/src/play/x11/playx.h:34: previous declaration of `font'
Lib/xplt/src/play/x11/playx.h:40: parse error before '}' token
Lib/xplt/src/play/x11/playx.h:40: warning: type
.
.
.
.
loseDisplay'
Lib/xplt/src/play/x11/errors.c:50: dereferencing pointer to incomplete type
error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall
-Wstrict-prototypes -fPIC -Ibuild/temp.linux-i686-2.4/config_pygist
-ILib/xplt/src/gist -ILib/xplt/src/play -ILib/xplt/src/play/unix
-I/usr/local/include/python2.4 -c Lib/xplt/src/play/x11/errors.c -o
build/temp.linux-i686-2.4/Lib/xplt/src/play/x11/errors.o
-DGISTPATH="\"/usr/local/lib/python2.4/site-packages/scipy/xplt/gistdata\"""
failed with exit status 1
[root at dhcp-222 SciPy_complete-0.3.2]#


It seems that there is some problems with the X11 headers or libraries.
What should I do to install them?

My operating system is Red Hat 9.0

Thanks for your time,

Adrián.



More information about the SciPy-user mailing list