[SciPy-user] how to get matplotlib working with new scipy?

Sven Schreiber svetosch at gmx.net
Fri Dec 2 10:53:16 CST 2005


Dear experienced scipy users,

I apologize if this is not the best/correct list to ask, but I joined only recently and so here goes:
I'd like to try matplotlib, and I have the new scipy (core & rest) installed on win32. After
installation, the command "from pylab import *" fails with the message "ImportError: No module named
Numeric". That's not too surprising, but I'm unsure about the best strategy to pursue.

Is matplotlib supposed to work with new scipy (alone, without extra numeric or numarray)? If so, how
do I have to set it up?

If numeric or numarray is still needed, is there any danger of "double definitions" of arrays etc.,
such that scripts could get confused or, worse, produce wrong results? (In theory I guess everything
should be fine, but I'd be glad to hear what's the actual status quo with respect to known bugs and
such.)

Thanks much for your help,
Sven



More information about the SciPy-user mailing list